Bug 225352 - clang 6.0.0 crashes building emulators/wine: Assertion failed: ((size_t)StackDisp < Context.ArgStoreVector.size() && "Function call has more parameters than the stack is adjusted for.")
Summary: clang 6.0.0 crashes building emulators/wine: Assertion failed: ((size_t)Stack...
Status: Closed DUPLICATE of bug 224863
Alias: None
Product: Base System
Classification: Unclassified
Component: bin (show other bugs)
Version: CURRENT
Hardware: amd64 Any
: --- Affects Some People
Assignee: freebsd-toolchain (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-01-21 11:05 UTC by Gerald Pfeifer
Modified: 2018-01-21 15:09 UTC (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Gerald Pfeifer freebsd_committer 2018-01-21 11:05:41 UTC
The import of clang 6.0.0 into -CURRENT broke both the emulators/wine
and emulators/wine-devel ports, with clang crashing:

http://beefy12.nyi.freebsd.org/data/head-amd64-default/p459147_s328035/logs/
wine-2.0.4,1.log
http://beefy12.nyi.freebsd.org/data/head-amd64-default/p459147_s328035/logs/
wine-devel-3.0.r6,1.log
http://beefy12.nyi.freebsd.org/data/head-amd64-default/p459306_s328104/logs/
wine-2.0.4,1.log
http://beefy12.nyi.freebsd.org/data/head-amd64-default/p459306_s328104/logs/
wine-devel-3.0.r6,1.log
http://beefy12.nyi.freebsd.org/data/head-amd64-default/p459491_s328183/logs/
wine-2.0.4,1.log
http://beefy12.nyi.freebsd.org/data/head-amd64-default/p459491_s328183/logs/
wine-devel-3.0.r6,1.log

Assertion failed: ((size_t)StackDisp < Context.ArgStoreVector.size() &&
"Function call has more parameters than the stack is adjusted for."),
function collectCallInfo, file
/usr/local/poudriere/jails/head-amd64/usr/src/contrib/llvm/lib/Target/X86/X8
6CallFrameOptimization.cpp, line 449.
cc: error: unable to execute command: Abort trap (core dumped)
cc: error: clang frontend command failed due to signal (use -v to see
invocation)
FreeBSD clang version 6.0.0 (branches/release_60 321788) (based on LLVM
6.0.0)
Comment 1 Dimitry Andric freebsd_committer 2018-01-21 15:09:36 UTC

*** This bug has been marked as a duplicate of bug 224863 ***