Bug 225395 - /usr/sbin/sade is useless when '/' is not on UFS
Summary: /usr/sbin/sade is useless when '/' is not on UFS
Status: New
Alias: None
Product: Base System
Classification: Unclassified
Component: bin (show other bugs)
Version: 11.1-RELEASE
Hardware: Any Any
: --- Affects Only Me
Assignee: freebsd-bugs mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-01-23 09:50 UTC by vermaden
Modified: 2018-01-23 09:50 UTC (History)
0 users

See Also:


Attachments
sade.png (21.97 KB, image/png)
2018-01-23 09:50 UTC, vermaden
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description vermaden 2018-01-23 09:50:27 UTC
Created attachment 189988 [details]
sade.png

Hi,

just tried to create new partition on a removable pendrive (da0) on a FreeBSD system where '/' is on ZFS (Boot Environment).

When I tried to 'Commit' the changes I got an error that a mountpoint of '/' must exist ... and sade is not able to detect one as its on ZFS.

Details in the attachement.

Plase modify /usr/sbin/sade so it will NOT check for the existing '/' mount, as its quite usable as 'graphical' partition manager in base.

Regards,
vermaden