Bug 225427 - devel/cl-asdf Please update to 3.3.1
Summary: devel/cl-asdf Please update to 3.3.1
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: Joseph Mingrone
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-01-24 12:17 UTC by bsd
Modified: 2018-04-17 14:15 UTC (History)
4 users (show)

See Also:
bugzilla: maintainer-feedback? (olgeni)


Attachments
patch updating port to 3.3.1.7 (3.17 KB, patch)
2018-03-13 14:48 UTC, Christian Heckendorf
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description bsd 2018-01-24 12:17:23 UTC
Could you please update cl-asdf to latest version, 3.3.1 (4 November 2017): https://gitlab.common-lisp.net/asdf/asdf

It is important, since latest version of SBCL, a major CL compiler, is now relying on it since version 1.4.2, but current SBCL package relies on very old 2016 version: http://sbcl.org/all-news.html#1.4.2
Comment 1 bsd 2018-01-24 13:23:04 UTC
Just as side information, this is ASDF warning when launching sbcl via SLIME, having ASDF at latest version (via quicklisp): 

 caught WARNING:
;   You are using ASDF version 3.3.1 (probably from (require "asdf") or loaded by
;   quicklisp) and have an older version of ASDF (and older than 2.27 at that)
;   registered at #P"/usr/local/lib/common-lisp/asdf/asdf.asd". Having an ASDF
;   installed and registered is the normal way of configuring ASDF to upgrade
;   itself, and having an old version registered is a configuration error. ASDF
;   will ignore this configured system rather than downgrade itself. In the future,
;   you may want to either: (a) upgrade this configured ASDF to a newer version,
;   (b) install a newer ASDF and register it in front of the former in your
;   configuration, or (c) uninstall or unregister this and any other old version of
;   ASDF from your configuration. Note that the older ASDF might be registered
;   implicitly through configuration inherited from your system installation, in
;   which case you might have to specify :ignore-inherited-configuration in your in
;   your ~/.config/common-lisp/source-registry.conf or other source-registry
;   configuration file, environment variable or lisp parameter. Indeed, a likely
;   offender is an obsolete version of the cl-asdf debian or ubuntu package, that
;   you might want to upgrade (if a recent enough version is available) or else
;   remove altogether (since most implementations ship with a recent asdf); if you
;   lack the system administration rights to upgrade or remove this package, then
;   you might indeed want to either install and register a more recent version, or
;   use :ignore-inherited-configuration to avoid registering the old one. Please
;   consult ASDF documentation and/or experts.
Comment 2 Christian Heckendorf 2018-03-13 14:48:56 UTC
Created attachment 191468 [details]
patch updating port to 3.3.1.7

Here's my attempt at updating the port to 3.3.1.7. SBCL no longer complains about asdf with this version installed. Poudriere testport is still unhappy about the absolute link for the registry but I'm not sure what the correct way to fix that is.
Comment 3 Christian Heckendorf 2018-03-13 15:26:29 UTC
I take it back, SBCL still complains.
Comment 4 bsd 2018-03-14 08:44:11 UTC
It is fine, that way you could include the latest version, coming soon:
https://github.com/fare/asdf/commit/8dc0778f734e70fd00ffc1c3491cf840ce92c4f0

:)
Comment 5 Ken Gunderson 2018-04-11 02:33:26 UTC
Any update on "coming soon"?
Comment 6 Joseph Mingrone freebsd_committer 2018-04-12 16:53:14 UTC
This looks good and I fixed the linking warning/issue.

Have you done run-time tests to confirm everything is in order?
Comment 7 Christian Heckendorf 2018-04-12 17:08:02 UTC
I think there are still issues to resolve, but I don't know enough about the language. When SBCL is first loaded with this patched cl-asdf installed, the reported warning doesn't show up anymore. The issue is that now I have trouble loading quicklisp for example.

I'm actually not sure why this package is listed as a dependency for SBCL, which bundles its own asdf, other than maybe to make use of some routines stored in devel/cl-asdf/bsd.cl-asdf.mk?

I'm no longer using CL but maybe this will be useful to someone that wants to look into it further.
Comment 8 Joseph Mingrone freebsd_committer 2018-04-12 17:54:54 UTC
It has been a while since I dug in this area, but devel/cl-asdf is required for the CL ports.  To use quicklisp, I think you want to remove this line from /usr/local/etc/sbclrc.

(load "/usr/local/etc/asdf-init.lisp")
Comment 9 commit-hook freebsd_committer 2018-04-12 17:56:54 UTC
A commit references this bug:

Author: jrm
Date: Thu Apr 12 17:56:43 UTC 2018
New revision: 467177
URL: https://svnweb.freebsd.org/changeset/ports/467177

Log:
  devel/cl-asdf: Update to version 3.3.1.7

  Port changes:
    - Pull tarball from Common-Lisp.net GitLab repository
    - Do not silence install commands (except mkdir)
    - Conform to 'Order of Variables in Port Makefiles' from Porter's
      Handbook
    - Silence warning about creating absolute links
    - Set DISTVERSION instead of setting PORTVERSION directly

  PR:		225427
  Submitted by:	Christian Heckendorf <heckendorfc@gmail.com>
  Approved by:	maintainer timeout (1 month)

Changes:
  head/devel/cl-asdf/Makefile
  head/devel/cl-asdf/distinfo
  head/devel/cl-asdf/files/patch-Makefile
  head/devel/cl-asdf/pkg-plist
Comment 10 Joseph Mingrone freebsd_committer 2018-04-12 17:58:28 UTC
Committed.  Thanks.
Comment 11 Ken Gunderson 2018-04-13 06:51:49 UTC
(In reply to Joseph Mingrone from comment #8)
Yes!  Thanks for that important tidbit.  Maybe there could be a port/pkg message added alerting quicklisp users?
Comment 12 Joseph Mingrone freebsd_committer 2018-04-17 14:15:02 UTC
(In reply to Ken Gunderson from comment #11)
A pkg-message has been added to lang/sbcl.