Bug 225465 - www/rubygem-rails4: Broke after last commit to rubygem-passenger
Summary: www/rubygem-rails4: Broke after last commit to rubygem-passenger
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Sunpoet Po-Chuan Hsieh
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-01-26 09:01 UTC by Daniel Ylitalo
Modified: 2018-01-27 18:43 UTC (History)
0 users

See Also:
bugzilla: maintainer-feedback? (ruby)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Daniel Ylitalo 2018-01-26 09:01:01 UTC
===>   rubygem-rails4-4.2.10 depends on package: rubygem-passenger>=2.2.15 - not found
*** Error code 1

Stop.
make: stopped in /usr/ports/www/rubygem-rails4
=>> Cleaning up wrkdir
===>  Cleaning for rubygem-rails4-4.2.10
build of www/rubygem-rails4 | rubygem-rails4-4.2.10 ended at Thu Jan 25 16:34:45 CET 2018
build time: 00:35:33
!!! build failure encountered !!!
Comment 1 commit-hook freebsd_committer 2018-01-27 18:43:02 UTC
A commit references this bug:

Author: sunpoet
Date: Sat Jan 27 18:42:56 UTC 2018
New revision: 460140
URL: https://svnweb.freebsd.org/changeset/ports/460140

Log:
  Fix PASSENGER_RUN_DEPENDS

  dvl@ introduced the FLAVOR support to www/rubygem-passenger in r459684 which adds PKGNAMESUFFIX.

  PR:		225465
  Reported by:	Daniel Ylitalo <daniel@blodan.se>

Changes:
  head/www/rubygem-rails4/Makefile
Comment 2 Sunpoet Po-Chuan Hsieh freebsd_committer 2018-01-27 18:43:53 UTC
Committed. Thanks!