Bug 225528 - Kernel panic pf purge
Summary: Kernel panic pf purge
Status: Closed DUPLICATE of bug 219251
Alias: None
Product: Base System
Classification: Unclassified
Component: kern (show other bugs)
Version: 11.1-RELEASE
Hardware: Any Any
: --- Affects Only Me
Assignee: freebsd-bugs mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-01-29 11:04 UTC by Andrei
Modified: 2018-01-29 11:55 UTC (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andrei 2018-01-29 11:04:34 UTC
Hello all,

Issue faced by me looks like https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=220830 , but I've checked and changes are from that bug are present.

Fatal trap 12: page fault while in kernel mode
cpuid = 21; apic id = 33
fault virtual address   = 0x5400
fault code              = supervisor write data, page not present
instruction pointer     = 0x20:0xffffffff824b2a05
stack pointer           = 0x28:0xfffffe046a004b00
frame pointer           = 0x28:0xfffffe046a004b20
code segment            = base rx0, limit 0xfffff, type 0x1b
                        = DPL 0, pres 1, long 1, def32 0, gran 1
processor eflags        = interrupt enabled, resume, IOPL = 0
current process         = 16 (pf purge)
trap number             = 12
panic: page fault
cpuid = 21
KDB: stack backtrace:
#0 0xffffffff80aae527 at kdb_backtrace+0x67
#1 0xffffffff80a6c146 at vpanic+0x186
#2 0xffffffff80a6bfb3 at panic+0x43
#3 0xffffffff80ef5832 at trap_fatal+0x322
#4 0xffffffff80ef5889 at trap_pfault+0x49
#5 0xffffffff80ef50c6 at trap+0x286
#6 0xffffffff80ed9ce1 at calltrap+0x8
#7 0xffffffff824b22b4 at pf_purge_expired_states+0x124
#8 0xffffffff824b2144 at pf_purge_thread+0x154
#9 0xffffffff80a2f955 at fork_exit+0x85
#10 0xffffffff80eda21e at fork_trampoline+0xe


➜  crash uname -a
FreeBSD xxxx.xxxx 11.1-RELEASE-p6 FreeBSD 11.1-RELEASE-p6 #0 r328517: Sun Jan 28 22:22:54 EET 2018     andrei@tower.local:/usr/obj/usr/src/sys/MY  amd64

Custom kernel used, but the only one difference with GENERIC is "options VIMAGE"
host is used for different jails managed by cbsd.
Panic usually occurs during startup or restart of jail or if tap device will be added.
Comment 1 Kristof Provost freebsd_committer 2018-01-29 11:37:36 UTC
You're running into PR 219251, which is fixed in head in r320848.
Comment 2 Andrei 2018-01-29 11:53:37 UTC
Oh, thanks.
Will try to patch.
Comment 3 Andrei 2018-01-29 11:55:37 UTC

*** This bug has been marked as a duplicate of bug 219251 ***