Bug 225588 - VirtualBox 5.2.6 guests freeze after a while, sometimes with I/O errors
Summary: VirtualBox 5.2.6 guests freeze after a while, sometimes with I/O errors
Status: New
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: amd64 Any
: --- Affects Only Me
Assignee: freebsd-virtualization mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-01-31 15:18 UTC by Jason W. Bacon
Modified: 2018-03-14 18:43 UTC (History)
3 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jason W. Bacon freebsd_committer 2018-01-31 15:18:45 UTC
Windows 10, CentOS 6, and CentOS 7 guests all consistently lock up after a while.  I haven't see the issue with FreeBSD guests yet, but I may just not have let them run long enough.

It seems to be related to disk activity.  All disk activity ceases while the VM is still running and showing CPU usage in both the host and the guest.

Eventually the guest freezes, sometimes showing I/O errors on the console.

The host X11 session becomes unresponsive to keyboard input while trying to power off the VM. I have to switch to a text console and kill the VirtualBox process to release it.
Comment 1 Jason W. Bacon freebsd_committer 2018-02-05 15:14:25 UTC
I torture-tested a FreeBSD 11.1 guest and it remained stable through heavy disk writes and sitting idle for nearly 24 hours.

CentOS guests are still crashing on one host (3 GHz Athlon64), but have become stable on another (2.9 GHz i7) after I ran package upgrades, although none of them seemed relevant to VirtualBox.  All hosts have fully updated packages and core and have been rebooted.
Comment 2 Jason W. Bacon freebsd_committer 2018-02-05 19:09:47 UTC
Scratch the comment about CentOS guests becoming stable on one of my hosts.  My CentOS 7 guest just froze on that host again.
Comment 3 Erik B Knudsen 2018-02-20 14:00:24 UTC
I can confirm this - I find the same behaviour with my windows 7 and 10 virtuals on my FreeBSD 11 host.
Comment 4 Jason W. Bacon freebsd_committer 2018-03-14 01:22:42 UTC
I'm not seeing this issue with CentOS in 5.2.8.  A Debian install that failed under 5.2.6 also worked under 5.2.8.

My Windows 10 guest still doesn't work, but that may be due to permanent damage caused by the previous failures, which happened during Windows Update.

I plan to try a fresh install when I get a chance, but that may be a while...
Comment 5 w.schwarzenfeld freebsd_triage 2018-03-14 05:32:11 UTC
bug #215526 seems a similar problem.
Comment 6 Jason W. Bacon freebsd_committer 2018-03-14 18:43:39 UTC
Interesting...

I spoke too soon about 5.2.8 solving the problem.  The latest round of CentOS Yum updates triggered it again.

I restored the .vdi file using an OVA snapshot and reran updates + zeroing free blocks (in prep for compressing the disk image).

Did this procedure twice, once with IDE and no host cache, and again with SATA and host cache.

No problems in either case.

So it looks like we may have a workaround.

It's still a mystery why this problem popped up in 5.2.6, though.  I've been running CentOS VMs for years and never had to care about controller settings.