Bug 225643 - lang/rust build failure at compiling rustc_driver
Summary: lang/rust build failure at compiling rustc_driver
Status: Closed DUPLICATE of bug 228892
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: arm64 Any
: --- Affects Some People
Assignee: FreeBSD Rust Team
URL: https://github.com/rust-lang/rust/iss...
Keywords:
Depends on:
Blocks:
 
Reported: 2018-02-03 05:48 UTC by gergely.czuczy
Modified: 2019-01-06 08:19 UTC (History)
2 users (show)

See Also:
dumbbell: maintainer-feedback+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description gergely.czuczy 2018-02-03 05:48:05 UTC
Hello,

When building rust on aarch64/-CURRENT(r328533M), after workarounding 225600 by swapping native with armv8, I'm getting the following build error:

   Compiling rustc_borrowck v0.0.0 (file:///usr/ports/lang/rust/work/rustc-1.23.0-src/src/librustc_borrowck)
error: internal compiler error: unexpected panic

note: the compiler unexpectedly panicked. this is a bug.

note: we would appreciate a bug report: https://github.com/rust-lang/rust/blob/master/CONTRIBUTING.md#bug-reports

note: rustc 1.23.0 running on aarch64-unknown-freebsd

thread 'rustc' panicked at 'other was less than the current instant', src/libstd/sys/unix/time.rs:284:16
note: Run with `RUST_BACKTRACE=1` for a backtrace.

error: Could not compile `rustc_driver`.

Caused by:
  process didn't exit successfully: `/usr/ports/lang/rust/work/rustc-1.23.0-src/build/bootstrap/debug/rustc --crate-name rustc_driver src/librustc_driver/lib.rs --error-format json --crate-type dylib --emit=dep-info,link -C prefer-dynamic -C opt-level=2 --cfg feature="llvm" --cfg feature="rustc_trans" -C metadata=a3a248164b9fca10 -C extra-filename=-a3a248164b9fca10 --out-dir /usr/ports/lang/rust/work/rustc-1.23.0-src/build/aarch64-unknown-freebsd/stage1-rustc/aarch64-unknown-freebsd/release/deps --target aarch64-unknown-freebsd -L dependency=/usr/ports/lang/rust/work/rustc-1.23.0-src/build/aarch64-unknown-freebsd/stage1-rustc/aarch64-unknown-freebsd/release/deps -L dependency=/usr/ports/lang/rust/work/rustc-1.23.0-src/build/aarch64-unknown-freebsd/stage1-rustc/release/deps --extern rustc_trans_utils=/usr/ports/lang/rust/work/rustc-1.23.0-src/build/aarch64-unknown-freebsd/stage1-rustc/aarch64-unknown-freebsd/release/deps/librustc_trans_utils-f26510fa78811706.so --extern rustc_back=/usr/ports/lang/rust/work/rustc-1.23.0-src/build/aarch64-unknown-freebsd/stage1-rustc/aarch64-unknown-freebsd/release/deps/librustc_back-a3a5b2bd056cbe32.so --extern owning_ref=/usr/ports/lang/rust/work/rustc-1.23.0-src/build/aarch64-unknown-freebsd/stage1-rustc/aarch64-unknown-freebsd/release/deps/libowning_ref-63bd539c74e1ad43.rlib --extern rustc_privacy=/usr/ports/lang/rust/work/rustc-1.23.0-src/build/aarch64-unknown-freebsd/stage1-rustc/aarch64-unknown-freebsd/release/deps/librustc_privacy-186ed14e87781c46.so --extern rustc_passes=/usr/ports/lang/rust/work/rustc-1.23.0-src/build/aarch64-unknown-freebsd/stage1-rustc/aarch64-unknown-freebsd/release/deps/librustc_passes-33579faf7eb08740.so --extern rustc=/usr/ports/lang/rust/work/rustc-1.23.0-src/build/aarch64-unknown-freebsd/stage1-rustc/aarch64-unknown-freebsd/release/deps/librustc-88421f2cb3ec171c.so --extern syntax=/usr/ports/lang/rust/work/rustc-1.23.0-src/build/aarch64-unknown-freebsd/stage1-rustc/aarch64-unknown-freebsd/release/deps/libsyntax-9720955d1827f646.so --extern graphviz=/usr/ports/lang/rust/work/rustc-1.23.0-src/build/aarch64-unknown-freebsd/stage1-rustc/aarch64-unknown-freebsd/release/deps/libgraphviz-4fea6315732d3d2f.so --extern syntax_ext=/usr/ports/lang/rust/work/rustc-1.23.0-src/build/aarch64-unknown-freebsd/stage1-rustc/aarch64-unknown-freebsd/release/deps/libsyntax_ext-63cd43902c76245b.so --extern rustc_resolve=/usr/ports/lang/rust/work/rustc-1.23.0-src/build/aarch64-unknown-freebsd/stage1-rustc/aarch64-unknown-freebsd/release/deps/librustc_resolve-c3913faa6425f6a9.so --extern rustc_incremental=/usr/ports/lang/rust/work/rustc-1.23.0-src/build/aarch64-unknown-freebsd/stage1-rustc/aarch64-unknown-freebsd/release/deps/librustc_incremental-f54997c797d290e7.so --extern rustc_lint=/usr/ports/lang/rust/work/rustc-1.23.0-src/build/aarch64-unknown-freebsd/stage1-rustc/aarch64-unknown-freebsd/release/deps/librustc_lint-35e6b31b6b5193b5.so --extern env_logger=/usr/ports/lang/rust/work/rustc-1.23.0-src/build/aarch64-unknown-freebsd/stage1-rustc/aarch64-unknown-freebsd/release/deps/libenv_logger-61ab10b7ba8609ba.rlib --extern rustc_save_analysis=/usr/ports/lang/rust/work/rustc-1.23.0-src/build/aarch64-unknown-freebsd/stage1-rustc/aarch64-unknown-freebsd/release/deps/librustc_save_analysis-0592fa0ae35e232a.so --extern rustc_metadata=/usr/ports/lang/rust/work/rustc-1.23.0-src/build/aarch64-unknown-freebsd/stage1-rustc/aarch64-unknown-freebsd/release/deps/librustc_metadata-18b0f3136714a43e.so --extern rustc_trans=/usr/ports/lang/rust/work/rustc-1.23.0-src/build/aarch64-unknown-freebsd/stage1-rustc/aarch64-unknown-freebsd/release/deps/librustc_trans-317ab8b75925d16d.so --extern log=/usr/ports/lang/rust/work/rustc-1.23.0-src/build/aarch64-unknown-freebsd/stage1-rustc/aarch64-unknown-freebsd/release/deps/liblog-83ed2b3da54da065.rlib --extern rustc_const_eval=/usr/ports/lang/rust/work/rustc-1.23.0-src/build/aarch64-unknown-freebsd/stage1-rustc/aarch64-unknown-freebsd/release/deps/librustc_const_eval-05b196e22aa70cdf.so --extern arena=/usr/ports/lang/rust/work/rustc-1.23.0-src/build/aarch64-unknown-freebsd/stage1-rustc/aarch64-unknown-freebsd/release/deps/libarena-65ac283e2181119c.so --extern serialize=/usr/ports/lang/rust/work/rustc-1.23.0-src/build/aarch64-unknown-freebsd/stage1-rustc/aarch64-unknown-freebsd/release/deps/libserialize-19d6ebe3e14c2d81.so --extern serialize=/usr/ports/lang/rust/work/rustc-1.23.0-src/build/aarch64-unknown-freebsd/stage1-rustc/aarch64-unknown-freebsd/release/deps/libserialize-19d6ebe3e14c2d81.rlib --extern rustc_data_structures=/usr/ports/lang/rust/work/rustc-1.23.0-src/build/aarch64-unknown-freebsd/stage1-rustc/aarch64-unknown-freebsd/release/deps/librustc_data_structures-ba341872e7991136.so --extern rustc_mir=/usr/ports/lang/rust/work/rustc-1.23.0-src/build/aarch64-unknown-freebsd/stage1-rustc/aarch64-unknown-freebsd/release/deps/librustc_mir-7cbb1a0cffa2f90a.so --extern rustc_errors=/usr/ports/lang/rust/work/rustc-1.23.0-src/build/aarch64-unknown-freebsd/stage1-rustc/aarch64-unknown-freebsd/release/deps/librustc_errors-b57a93fd76b69004.so --extern syntax_pos=/usr/ports/lang/rust/work/rustc-1.23.0-src/build/aarch64-unknown-freebsd/stage1-rustc/aarch64-unknown-freebsd/release/deps/libsyntax_pos-4a2ba02b1d316d6a.so --extern rustc_borrowck=/usr/ports/lang/rust/work/rustc-1.23.0-src/build/aarch64-unknown-freebsd/stage1-rustc/aarch64-unknown-freebsd/release/deps/librustc_borrowck-ff5038dd4ae6c523.so --extern rustc_typeck=/usr/ports/lang/rust/work/rustc-1.23.0-src/build/aarch64-unknown-freebsd/stage1-rustc/aarch64-unknown-freebsd/release/deps/librustc_typeck-4dec9bfa76e487f7.so --extern rustc_plugin=/usr/ports/lang/rust/work/rustc-1.23.0-src/build/aarch64-unknown-freebsd/stage1-rustc/aarch64-unknown-freebsd/release/deps/librustc_plugin-a85cffab17462240.so --extern rustc_allocator=/usr/ports/lang/rust/work/rustc-1.23.0-src/build/aarch64-unknown-freebsd/stage1-rustc/aarch64-unknown-freebsd/release/deps/librustc_allocator-f6c447de9905625a.so --extern ar=/usr/ports/lang/rust/work/rustc-1.23.0-src/build/aarch64-unknown-freebsd/stage1-rustc/aarch64-unknown-freebsd/release/deps/libar-5f0d891fd82be381.rlib -L native=/usr/ports/lang/rust/work/rustc-1.23.0-src/build/aarch64-unknown-freebsd/stage1-rustc/aarch64-unknown-freebsd/release/build/miniz-sys-e6cdcc5603fc9027/out -L native=/usr/ports/lang/rust/work/rustc-1.23.0-src/build/aarch64-unknown-freebsd/stage1-rustc/aarch64-unknown-freebsd/release/build/rustc_binaryen-97e9aebd5f88f774/out/build/lib -L native=/usr/ports/lang/rust/work/rustc-1.23.0-src/build/aarch64-unknown-freebsd/stage1-rustc/aarch64-unknown-freebsd/release/build/rustc_binaryen-97e9aebd5f88f774/out -L native=/usr/ports/lang/rust/work/rustc-1.23.0-src/build/aarch64-unknown-freebsd/stage1-rustc/aarch64-unknown-freebsd/release/build/rustc_llvm-a9214ed59bd74bf2/out -L native=/usr/ports/lang/rust/work/rustc-1.23.0-src/build/aarch64-unknown-freebsd/llvm/lib` (exit code: 101)
thread 'main' panicked at 'command did not execute successfully: "/usr/ports/lang/rust/work/rustc-1.23.0-src/build/aarch64-unknown-freebsd/stage0/bin/cargo" "build" "--target" "aarch64-unknown-freebsd" "--release" "--frozen" "--features" " jemalloc llvm" "--manifest-path" "/usr/ports/lang/rust/work/rustc-1.23.0-src/src/rustc/Cargo.toml" "--message-format" "json"
expected success, got: exit code: 101', src/bootstrap/compile.rs:882:8
note: Run with `RUST_BACKTRACE=1` for a backtrace.
Traceback (most recent call last):
  File "/usr/ports/lang/rust/work/rustc-1.23.0-src/x.py", line 20, in <module>
    bootstrap.main()
  File "/usr/ports/lang/rust/work/rustc-1.23.0-src/src/bootstrap/bootstrap.py", line 758, in main
    bootstrap()
  File "/usr/ports/lang/rust/work/rustc-1.23.0-src/src/bootstrap/bootstrap.py", line 749, in bootstrap
    run(args, env=env, verbose=build.verbose)
  File "/usr/ports/lang/rust/work/rustc-1.23.0-src/src/bootstrap/bootstrap.py", line 148, in run
    raise RuntimeError(err)
RuntimeError: failed to run: /usr/ports/lang/rust/work/rustc-1.23.0-src/build/bootstrap/debug/bootstrap build --verbose --config ./config.toml --jobs 4
*** Error code 1

Stop.
make[1]: stopped in /usr/ports/lang/rust
*** Error code 1

Stop.
make: stopped in /usr/ports/lang/rust

Could someone please look into it?

Best regards,
Gergely
Comment 1 Jean-Sébastien Pédron freebsd_committer 2018-02-19 22:03:48 UTC
Hi!

I just updated lang/rust to 1.24.0 which comes with a new bootstrap (1.23.0). The bootstrap is cross-compiled on amd64, but this time based on 11.1-RELEASE, not 11.0-RELEASE.

I don't have any aarch64 Poudriere host to test the port, so each update to the port is untested on aarch64 :(
Comment 2 gergely.czuczy 2018-02-21 20:45:06 UTC
I was told by the #bsdmips guys, there are test machine for such purposes, and was given the following links:

https://wiki.freebsd.org/TestClusterOneReservations
https://www.freebsd.org/internal/machines.html

I think you could test the build on that one.

In the meantime I will check the new build, with manually applied fixes for PR 225600
Comment 3 gergely.czuczy 2018-02-23 05:30:41 UTC
It failed with the updated port as well.

I've opened an issue with rustc just in case: https://github.com/rust-lang/rust/issues/48459
Comment 4 Tobias Kortkamp freebsd_committer 2019-01-06 08:19:30 UTC

*** This bug has been marked as a duplicate of bug 228892 ***