Bug 225665 - Update ELK stack to 5.6.8
Summary: Update ELK stack to 5.6.8
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Tom Judge
URL:
Keywords:
: 222260 223395 223439 223450 (view as bug list)
Depends on:
Blocks:
 
Reported: 2018-02-04 18:46 UTC by John W. O'Brien
Modified: 2018-02-25 14:11 UTC (History)
5 users (show)

See Also:
pi: maintainer-feedback-


Attachments
svn-diff-logstash5-5.6.8 (83.05 KB, application/zip)
2018-02-24 04:53 UTC, Walter Schwarzenfeld
no flags Details
svn-diff-kibana5-5.6.8 (153.09 KB, application/octet-stream)
2018-02-24 05:32 UTC, Walter Schwarzenfeld
no flags Details
svn-diff-kibana5-5.6.8 (153.09 KB, application/zip)
2018-02-24 05:33 UTC, Walter Schwarzenfeld
no flags Details
svn-diff-kibana5-x-pack-5.6.8 (153.09 KB, application/zip)
2018-02-24 06:24 UTC, Walter Schwarzenfeld
no flags Details
svn-diff-kibana5-5.6.8_v2 (153.17 KB, application/zip)
2018-02-24 06:29 UTC, Walter Schwarzenfeld
no flags Details
svn-diff-elasticsearch5-5.6.8 (13.24 KB, patch)
2018-02-24 06:53 UTC, Walter Schwarzenfeld
no flags Details | Diff
svn-diff-elasticsearch5-x-pack-5.6.8 (9.11 KB, patch)
2018-02-24 06:59 UTC, Walter Schwarzenfeld
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description John W. O'Brien 2018-02-04 18:46:07 UTC
Ports affected:

    sysutils/logstash5
    textproc/elasticsearch5-x-pack
    textproc/elasticsearch5
    textproc/kibana5-x-pack
    textproc/kibana5

See review D14003 for changelog and patches.
Comment 1 John W. O'Brien 2018-02-04 20:27:38 UTC
Bumping to 5.6.7 following new release on 2018-01-30.
Comment 2 Kurt Jaeger freebsd_committer 2018-02-05 20:56:35 UTC
*** Bug 223439 has been marked as a duplicate of this bug. ***
Comment 3 Kurt Jaeger freebsd_committer 2018-02-05 20:57:08 UTC
*** Bug 223450 has been marked as a duplicate of this bug. ***
Comment 4 John W. O'Brien 2018-02-05 23:44:41 UTC
Note that as of a few hours ago both bug 223439 and bug 223450 have exceeded the three month maintainer timeout threshold after which the maintainer is considered AWOL and may be replaced per [0].

Kurt, I would consider taking on maintainership, though it would probably be better if you did.

[0] https://www.freebsd.org/doc/en/books/porters-handbook/makefile-maintainer.html
Comment 5 John W. O'Brien 2018-02-05 23:56:01 UTC
bug 223395 is a duplicate w.r.t. sysutils/logstash5 and has also exceeded the three month maintainer timeout. FWIW, somebody should also close bug 222260 as a duplicate that was obsoleted by bug 223395. I can't even mark the duplicates let alone resolve them.
Comment 6 Kurt Jaeger freebsd_committer 2018-02-06 05:42:44 UTC
*** Bug 222260 has been marked as a duplicate of this bug. ***
Comment 7 Kurt Jaeger freebsd_committer 2018-02-11 19:56:53 UTC
*** Bug 223395 has been marked as a duplicate of this bug. ***
Comment 8 Patrice 2018-02-23 14:05:48 UTC
(In reply to John W. O'Brien from comment #5)

Hello,

do you have an estimated date of resolution for these issues?

We have made patches for elasticsearch5-5.6.4 in the past and were willing to help integrate those into the ports tree.

Thanks,
Comment 9 Kurt Jaeger freebsd_committer 2018-02-23 21:00:01 UTC
testbuilds@work
Comment 10 Patrice 2018-02-23 21:02:46 UTC
(In reply to Kurt Jaeger from comment #9)

Hello,

We are not familiar with your wordings, would you mind clarifying your point?

Thanks,
Comment 11 Walter Schwarzenfeld freebsd_triage 2018-02-24 04:53:34 UTC
Created attachment 190929 [details]
svn-diff-logstash5-5.6.8

For the changes in logstash.in see Bug #217368.

ChangeLogs from 5.6.0 - 5.6.8:

https://www.elastic.co/guide/en/logstash/5.6/releasenotes.html
Comment 12 Walter Schwarzenfeld freebsd_triage 2018-02-24 04:54:37 UTC
The svn-diff is ".zip".
Comment 13 Walter Schwarzenfeld freebsd_triage 2018-02-24 05:32:52 UTC
Created attachment 190933 [details]
svn-diff-kibana5-5.6.8
Comment 14 Walter Schwarzenfeld freebsd_triage 2018-02-24 05:33:45 UTC
Created attachment 190934 [details]
svn-diff-kibana5-5.6.8
Comment 15 Walter Schwarzenfeld freebsd_triage 2018-02-24 05:44:48 UTC
Forgot ChangeLog kibana5 5.3.1 - 5.6.8
https://www.elastic.co/guide/en/kibana/5.6/release-notes.html
Comment 16 Walter Schwarzenfeld freebsd_triage 2018-02-24 06:24:20 UTC
Created attachment 190936 [details]
svn-diff-kibana5-x-pack-5.6.8

https://www.elastic.co/guide/en/x-pack/5.6/xpack-change-list.html
Comment 17 Walter Schwarzenfeld freebsd_triage 2018-02-24 06:29:34 UTC
Created attachment 190938 [details]
svn-diff-kibana5-5.6.8_v2

Forgot change node version.
Comment 18 Walter Schwarzenfeld freebsd_triage 2018-02-24 06:53:33 UTC
Created attachment 190939 [details]
svn-diff-elasticsearch5-5.6.8
Comment 19 Walter Schwarzenfeld freebsd_triage 2018-02-24 06:59:37 UTC
Created attachment 190940 [details]
svn-diff-elasticsearch5-x-pack-5.6.8

ChangeLog:
https://www.elastic.co/guide/en/x-pack/5.6/xpack-change-list.html
Comment 20 Walter Schwarzenfeld freebsd_triage 2018-02-24 16:23:17 UTC
Done with:
https://svnweb.freebsd.org/ports?view=revision&revision=462830
Comment 21 Patrice 2018-02-25 08:18:52 UTC
(In reply to w.schwarzenfeld from comment #20)

Hi,

the elasticsearch5 5.6.8 is broken in regards to JNA. We have made patches available for 5.6.4 in the past which took care of that issue. We don't see the relevant code into this 5.6.8.

As a result, elasticsearch5 5.6.8 refuses to start with the following warnings and errors:

[2018-02-25T09:09:04,373][WARN ][o.e.b.Natives            ] unable to load JNA native support library, native methods will be disabled.
java.lang.UnsatisfiedLinkError: Native library (com/sun/jna/freebsd-x86-64/libjnidispatch.so) not found in resource path ([file:/usr/local/lib/elasticsearch/lib/java-version-checker-5.6.8.jar, file:/usr/local/lib/elasticsearch/lib/joda-time-2.9.5.jar, file:/usr/local/lib/elasticsearch/lib/lucene-spatial-extras-6.6.1.jar, file:/usr/local/lib/elasticsearch/lib/lucene-join-6.6.1.jar, file:/usr/local/lib/elasticsearch/lib/lucene-misc-6.6.1.jar, file:/usr/local/lib/elasticsearch/lib/lucene-queries-6.6.1.jar, file:/usr/local/lib/elasticsearch/lib/lucene-queryparser-6.6.1.jar, file:/usr/local/lib/elasticsearch/lib/lucene-sandbox-6.6.1.jar, file:/usr/local/lib/elasticsearch/lib/lucene-spatial-6.6.1.jar, file:/usr/local/lib/elasticsearch/lib/HdrHistogram-2.1.9.jar, file:/usr/local/lib/elasticsearch/lib/hppc-0.7.1.jar, file:/usr/local/lib/elasticsearch/lib/elasticsearch-5.6.8.jar, file:/usr/local/lib/elasticsearch/lib/jopt-simple-5.0.2.jar, file:/usr/local/lib/elasticsearch/lib/jts-1.13.jar, file:/usr/local/lib/elasticsearch/lib/log4j-1.2-api-2.9.1.jar, file:/usr/local/lib/elasticsearch/lib/log4j-api-2.9.1.jar, file:/usr/local/lib/elasticsearch/lib/log4j-core-2.9.1.jar, file:/usr/local/lib/elasticsearch/lib/lucene-analyzers-common-6.6.1.jar, file:/usr/local/lib/elasticsearch/lib/lucene-backward-codecs-6.6.1.jar, file:/usr/local/lib/elasticsearch/lib/lucene-core-6.6.1.jar, file:/usr/local/lib/elasticsearch/lib/lucene-grouping-6.6.1.jar, file:/usr/local/lib/elasticsearch/lib/lucene-highlighter-6.6.1.jar, file:/usr/local/lib/elasticsearch/lib/lucene-memory-6.6.1.jar, file:/usr/local/lib/elasticsearch/lib/lucene-spatial3d-6.6.1.jar, file:/usr/local/lib/elasticsearch/lib/lucene-suggest-6.6.1.jar, file:/usr/local/lib/elasticsearch/lib/jackson-core-2.8.6.jar, file:/usr/local/lib/elasticsearch/lib/jna-4.4.0-1.jar, file:/usr/local/lib/elasticsearch/lib/plugin-cli-5.6.8.jar, file:/usr/local/lib/elasticsearch/lib/securesm-1.2.jar, file:/usr/local/lib/elasticsearch/lib/snakeyaml-1.15.jar, file:/usr/local/lib/elasticsearch/lib/spatial4j-0.6.jar, file:/usr/local/lib/elasticsearch/lib/t-digest-3.0.jar, file:/usr/local/lib/elasticsearch/lib/jackson-dataformat-cbor-2.8.6.jar, file:/usr/local/lib/elasticsearch/lib/jackson-dataformat-smile-2.8.6.jar, file:/usr/local/lib/elasticsearch/lib/jackson-dataformat-yaml-2.8.6.jar])
        at com.sun.jna.Native.loadNativeDispatchLibraryFromClasspath(Native.java:962) ~[jna-4.4.0-1.jar:4.4.0 (b0)]
        at com.sun.jna.Native.loadNativeDispatchLibrary(Native.java:922) ~[jna-4.4.0-1.jar:4.4.0 (b0)]
        at com.sun.jna.Native.<clinit>(Native.java:190) ~[jna-4.4.0-1.jar:4.4.0 (b0)]
        at java.lang.Class.forName0(Native Method) ~[?:1.8.0_162]
        at java.lang.Class.forName(Class.java:264) ~[?:1.8.0_162]
        at org.elasticsearch.bootstrap.Natives.<clinit>(Natives.java:45) [elasticsearch-5.6.8.jar:5.6.8]
        at org.elasticsearch.bootstrap.Bootstrap.initializeNatives(Bootstrap.java:105) [elasticsearch-5.6.8.jar:5.6.8]
        at org.elasticsearch.bootstrap.Bootstrap.setup(Bootstrap.java:195) [elasticsearch-5.6.8.jar:5.6.8]
        at org.elasticsearch.bootstrap.Bootstrap.init(Bootstrap.java:342) [elasticsearch-5.6.8.jar:5.6.8]
        at org.elasticsearch.bootstrap.Elasticsearch.init(Elasticsearch.java:132) [elasticsearch-5.6.8.jar:5.6.8]
        at org.elasticsearch.bootstrap.Elasticsearch.execute(Elasticsearch.java:123) [elasticsearch-5.6.8.jar:5.6.8]
        at org.elasticsearch.cli.EnvironmentAwareCommand.execute(EnvironmentAwareCommand.java:70) [elasticsearch-5.6.8.jar:5.6.8]
        at org.elasticsearch.cli.Command.mainWithoutErrorHandling(Command.java:134) [elasticsearch-5.6.8.jar:5.6.8]
        at org.elasticsearch.cli.Command.main(Command.java:90) [elasticsearch-5.6.8.jar:5.6.8]
        at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:91) [elasticsearch-5.6.8.jar:5.6.8]
        at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:84) [elasticsearch-5.6.8.jar:5.6.8]
[2018-02-25T09:09:04,394][WARN ][o.e.b.Natives            ] cannot check if running as root because JNA is not available
[2018-02-25T09:09:04,394][WARN ][o.e.b.Natives            ] cannot install system call filter because JNA is not available
[2018-02-25T09:09:04,394][WARN ][o.e.b.Natives            ] cannot mlockall because JNA is not available
[2018-02-25T09:09:04,395][WARN ][o.e.b.Natives            ] cannot register console handler because JNA is not available
[2018-02-25T09:09:04,398][WARN ][o.e.b.Natives            ] cannot getrlimit RLIMIT_NPROC because JNA is not available
[2018-02-25T09:09:04,398][WARN ][o.e.b.Natives            ] cannot getrlimit RLIMIT_AS beacuse JNA is not available
[2018-02-25T09:09:04,398][WARN ][o.e.b.Natives            ] cannot getrlimit RLIMIT_FSIZE because JNA is not available


And a little bit later on:

[2018-02-25T09:09:15,242][ERROR][o.e.b.Bootstrap          ] [dnode] node validation exception
[2] bootstrap checks failed
[1]: memory locking requested for elasticsearch process but memory is not locked
[2]: system call filters failed to install; check the logs and fix your configuration or disable system call filters at your own risk
[2018-02-25T09:09:15,244][INFO ][o.e.n.Node               ] [dnode] stopping ...
Comment 22 Walter Schwarzenfeld freebsd_triage 2018-02-25 14:08:54 UTC
Reopen.
Comment 23 Walter Schwarzenfeld freebsd_triage 2018-02-25 14:11:55 UTC
Bug # 222261  is already open. So it is not needed here.