Bug 225733 - [PATCH] x11/xterm: option LUIT relies on option WCHAR
Summary: [PATCH] x11/xterm: option LUIT relies on option WCHAR
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Emanuel Haupt
URL:
Keywords: patch
Depends on:
Blocks:
 
Reported: 2018-02-07 17:32 UTC by Kai Knoblich
Modified: 2018-02-10 08:20 UTC (History)
0 users

See Also:
bugzilla: maintainer-feedback? (ehaupt)


Attachments
Patch to make option WCHAR implicit (574 bytes, patch)
2018-02-07 17:32 UTC, Kai Knoblich
no flags Details | Diff
configure with LUIT enabled and WCHAR disabled (139.53 KB, text/x-log)
2018-02-07 17:36 UTC, Kai Knoblich
no flags Details
configure with LUIT enabled and WCHAR enabled (140.22 KB, text/x-log)
2018-02-07 17:37 UTC, Kai Knoblich
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Kai Knoblich freebsd_committer 2018-02-07 17:32:53 UTC
Created attachment 190389 [details]
Patch to make option WCHAR implicit

This bug occurs only when the port is configured and built individually.

How to reproduce:
~~~~~~~~~~~~~~~~~
Compile the port with options LUIT enabled and WCHAR disabled.

What happens:
~~~~~~~~~~~~~
The port compiles without problems but the enabled option LUIT is silently ignored because it relies on the WCHAR option which was disabled.

This can be verified if the configure command will be used with the following parameters:

./configure --with-luit --disable-wide-chars

The option '--with-luit' is silently ignored and xterm will have no luit filter and unicode support. 

If the configure command as listed below will be used instead, xterm is compiled with luit filter and unicode support:

./configure --with-luit --enable-wide-chars 

Resolution:
~~~~~~~~~~~
The option WCHAR should be enabled implicitly when option LUIT is enabled. Attached with this PR is the patch.

QA:
~~
- portlint: ok
- poudriere (11.1-RELEASE amd64): ok
Comment 1 Kai Knoblich freebsd_committer 2018-02-07 17:36:51 UTC
Created attachment 190390 [details]
configure with LUIT enabled and WCHAR disabled
Comment 2 Kai Knoblich freebsd_committer 2018-02-07 17:37:15 UTC
Created attachment 190391 [details]
configure with LUIT enabled and WCHAR enabled
Comment 3 commit-hook freebsd_committer 2018-02-10 08:11:56 UTC
A commit references this bug:

Author: ehaupt
Date: Sat Feb 10 08:11:26 UTC 2018
New revision: 461363
URL: https://svnweb.freebsd.org/changeset/ports/461363

Log:
  - Update to 331
  - WCHAR options requires print/freetype2
  - LUIT option implies the WCHAR option [1]
  - Provide a TOOLBAR option [2]

  PR:		225733 [1]
  Submitted by:	180126-bugzilla_freebsd_org@k-worx.org [1],
  		schweikh@schweikhardt.net (via mail) [2]

Changes:
  head/x11/xterm/Makefile
  head/x11/xterm/distinfo
Comment 4 Emanuel Haupt freebsd_committer 2018-02-10 08:20:19 UTC
Committed, thank you very much.