Bug 225800 - [patch] mail/mailman: fix to make 'service mailman reopen' to work
Summary: [patch] mail/mailman: fix to make 'service mailman reopen' to work
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: Matthias Andree
URL:
Keywords: patch
Depends on:
Blocks:
 
Reported: 2018-02-10 05:52 UTC by Yasuhito FUTATSUKI
Modified: 2018-02-11 22:38 UTC (History)
0 users

See Also:
mandree: maintainer-feedback+


Attachments
patch against file/patch-misc__mailman.in (r461277) (975 bytes, patch)
2018-02-10 05:52 UTC, Yasuhito FUTATSUKI
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Yasuhito FUTATSUKI 2018-02-10 05:52:52 UTC
Created attachment 190475 [details]
patch against file/patch-misc__mailman.in (r461277)

The patch-misc__mailman.in changed at r461277 cannot make use of 'mailmanctl reopen' feature. (perhaps caused by miss of auto merge)

This patch try to make it work.
Comment 1 commit-hook freebsd_committer 2018-02-11 22:36:33 UTC
A commit references this bug:

Author: mandree
Date: Sun Feb 11 22:36:07 UTC 2018
New revision: 461534
URL: https://svnweb.freebsd.org/changeset/ports/461534

Log:
  Support the upstream "reopen" mode (broken from the beginning in ports)

  When the upstream initscript grew a "reopen" mode with 2.1.17 in late 2013,
  our patch stuffed the usage information into the wrong place, so that we
  inadvertently disabled the new reopen mode, thus never supported it
  through the init script in FreeBSD.

  Bump PORTREVISION.

  PR:		225800
  Submitted by:	Yasuhito FUTATSUKI
  MFH:		2018Q1

Changes:
  head/mail/mailman/Makefile
  head/mail/mailman/files/patch-misc__mailman.in
Comment 2 Matthias Andree freebsd_committer 2018-02-11 22:38:31 UTC
Hello Yasuhito-san,

thank you very much for the patch. I have applied it. However, we have always - since Mailman had this reopen option - broken the init script in the same way, this was not a new bug but one that had been standing for more than four years. 

So all the better that you have fixed and reported it. Thanks again.