Bug 225885 - mail/cclient: Unbreak with openssl-devel
Summary: mail/cclient: Unbreak with openssl-devel
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Thomas Zander
URL:
Keywords: patch, patch-ready
Depends on:
Blocks: 228865
  Show dependency treegraph
 
Reported: 2018-02-14 11:46 UTC by Bernard Spil
Modified: 2018-06-10 11:16 UTC (History)
2 users (show)

See Also:
riggs: merge-quarterly+


Attachments
svn diff for mail/cclient (2.32 KB, text/plain)
2018-02-14 11:46 UTC, Bernard Spil
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Bernard Spil freebsd_committer 2018-02-14 11:46:54 UTC
Created attachment 190610 [details]
svn diff for mail/cclient

```
lang/python34: Unbreak with openssl-devel

 - x509_st is opaque in 1.1.x

PR:
```

Use methods to access certificate properties, not direct access to struct.
Comment 1 commit-hook freebsd_committer 2018-03-10 14:45:26 UTC
A commit references this bug:

Author: riggs
Date: Sat Mar 10 14:44:28 UTC 2018
New revision: 464076
URL: https://svnweb.freebsd.org/changeset/ports/464076

Log:
  Un-break with SSL OPTION (default)

  PR:		225885
  Submitted by:	brnrd
  MFH:		2018Q1

Changes:
  head/mail/cclient/Makefile
  head/mail/cclient/files/patch-src_osdep_unix_ssl__unix.c
Comment 2 commit-hook freebsd_committer 2018-03-10 14:57:37 UTC
A commit references this bug:

Author: riggs
Date: Sat Mar 10 14:57:09 UTC 2018
New revision: 464077
URL: https://svnweb.freebsd.org/changeset/ports/464077

Log:
  MFH: r464076

  Un-break with SSL OPTION (default)

  PR:		225885
  Submitted by:	brnrd

  Approved by:	ports-secteam (riggs)

Changes:
_U  branches/2018Q1/
  branches/2018Q1/mail/cclient/Makefile
  branches/2018Q1/mail/cclient/files/patch-src_osdep_unix_ssl__unix.c
Comment 3 Dani 2018-03-27 05:17:00 UTC
Please take a look at bug #226621 - looks like this PR caused a regression for multiple ports.