Bug 225898 - lang/erlang: Fails to build with OpenSSL 1.1
Summary: lang/erlang: Fails to build with OpenSSL 1.1
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Jean-Sébastien Pédron
URL:
Keywords: needs-qa, patch
: 228894 (view as bug list)
Depends on:
Blocks: 228865 231931
  Show dependency treegraph
 
Reported: 2018-02-14 17:26 UTC by Bernard Spil
Modified: 2018-11-06 14:12 UTC (History)
1 user (show)

See Also:
bugzilla: maintainer-feedback? (olgeni)


Attachments
svn diff for lang/erlang (39.36 KB, text/plain)
2018-02-14 17:26 UTC, Bernard Spil
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Bernard Spil freebsd_committer 2018-02-14 17:26:27 UTC
Created attachment 190629 [details]
svn diff for lang/erlang

```
lang/erlang: Fix build with openssl-devel

 - Backport OpenSSL 1.1.0 changes from 20.x

PR:
```
from: https://github.com/erlang/otp/commit/458c012e18eda87803ef356221d68955f4b8012d#diff-982b04bd4ee9242a74ca39b0de89fafb
Comment 1 Bernard Spil freebsd_committer 2018-06-15 09:26:25 UTC
During BSDCan 2018 the intention to update OpenSSL in base to 1.1.x branch was documented.

Intention is to update 12-STABLE to current 1.1.0 and subsequently update it to 1.1.1 when that is released. The intent to update OpenSSL to 1.1 in 12 has now officially been documented in Bug #228912
Comment 2 Bernard Spil freebsd_committer 2018-06-15 09:39:20 UTC
*** Bug 228894 has been marked as a duplicate of this bug. ***
Comment 5 Antoine Brodin freebsd_committer 2018-10-06 06:19:18 UTC
(In reply to Bernard Spil from comment #0)
Since the code changes, there should be a PORTREVISION bump.
Comment 6 Jean-Sébastien Pédron freebsd_committer 2018-11-05 17:52:15 UTC
In addition to the patch attached to this PR, I also needed the following patch:
https://github.com/erlang/otp/commit/4dddb3c0b286e13f2cbccb0cdaa4bffcfee60033

I'm now testing with lang/erlang (Erlang 19.x).
Comment 7 commit-hook freebsd_committer 2018-11-05 23:21:18 UTC
A commit references this bug:

Author: dumbbell
Date: Mon Nov  5 23:20:19 UTC 2018
New revision: 484254
URL: https://svnweb.freebsd.org/changeset/ports/484254

Log:
  lang/erlang, lang/erlang-runtime*: Indicate which port supports OpenSSL 1.1

  With some patching [1], Erlang 19.x supports OpenSSL 1.1.x (lang/erlang,
  lang/erlang-runtime19).

  However, previous versions are now marked as broken with OpenSSL 1.1.x.

  PR:		225898
  Submitted by:	brnrd [1]
  Obtained from:	Upstream

Changes:
  head/lang/erlang/Makefile
  head/lang/erlang/files/patch-OpenSSL-1.1-a
  head/lang/erlang/files/patch-OpenSSL-1.1-b
  head/lang/erlang-runtime15/Makefile
  head/lang/erlang-runtime16/Makefile
  head/lang/erlang-runtime17/Makefile
  head/lang/erlang-runtime18/Makefile
  head/lang/erlang-runtime19/Makefile
  head/lang/erlang-runtime19/files/patch-OpenSSL-1.1-a
  head/lang/erlang-runtime19/files/patch-OpenSSL-1.1-b
Comment 8 commit-hook freebsd_committer 2018-11-06 14:12:34 UTC
A commit references this bug:

Author: dumbbell
Date: Tue Nov  6 14:12:23 UTC 2018
New revision: 484291
URL: https://svnweb.freebsd.org/changeset/ports/484291

Log:
  MFH: r484254

  lang/erlang, lang/erlang-runtime*: Indicate which port supports OpenSSL 1.1

  With some patching [1], Erlang 19.x supports OpenSSL 1.1.x (lang/erlang,
  lang/erlang-runtime19).

  However, previous versions are now marked as broken with OpenSSL 1.1.x.

  PR:		225898
  Submitted by:	brnrd [1]
  Obtained from:	Upstream

  Approved by:	portmgr (miwi)

Changes:
_U  branches/2018Q4/
  branches/2018Q4/lang/erlang/Makefile
  branches/2018Q4/lang/erlang/files/patch-OpenSSL-1.1-a
  branches/2018Q4/lang/erlang/files/patch-OpenSSL-1.1-b
  branches/2018Q4/lang/erlang-runtime15/Makefile
  branches/2018Q4/lang/erlang-runtime16/Makefile
  branches/2018Q4/lang/erlang-runtime17/Makefile
  branches/2018Q4/lang/erlang-runtime18/Makefile
  branches/2018Q4/lang/erlang-runtime19/Makefile
  branches/2018Q4/lang/erlang-runtime19/files/patch-OpenSSL-1.1-a
  branches/2018Q4/lang/erlang-runtime19/files/patch-OpenSSL-1.1-b