Bug 225920 - devel/qca: Update to 2.1.3
Summary: devel/qca: Update to 2.1.3
Status: Closed Overcome By Events
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: kde
URL:
Keywords: needs-qa, patch
Depends on:
Blocks: 228865
  Show dependency treegraph
 
Reported: 2018-02-15 15:18 UTC by Bernard Spil
Modified: 2018-10-20 19:36 UTC (History)
2 users (show)

See Also:
rakuco: maintainer-feedback+


Attachments
svn diff for devel/qca (8.74 KB, patch)
2018-02-15 15:19 UTC, Bernard Spil
no flags Details | Diff
svn diff for devel/qca (16.27 KB, patch)
2018-02-15 19:25 UTC, Bernard Spil
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Bernard Spil freebsd_committer 2018-02-15 15:18:45 UTC
```
devel/qca: Fix build with OpenSSL 1.1

 * Backport upstream fix

PR:
```

Working on updating the OpenSSL port to 1.1 which will require this patch
Comment 1 Bernard Spil freebsd_committer 2018-02-15 15:19:20 UTC
Created attachment 190651 [details]
svn diff for devel/qca
Comment 2 Tobias C. Berner freebsd_committer 2018-02-15 16:45:00 UTC
Moin moin

So at the moment this just adds the patch which creates a new header file, which will be used once ossl is updated? 


Mfg Tobias
Comment 3 Bernard Spil freebsd_committer 2018-02-15 19:25:17 UTC
Created attachment 190664 [details]
svn diff for devel/qca

Sorry to bother you again... That wasn't completely functional yet.

I've updated the port to 2.1.3 and added the patch from upstream.

Please let me know if this is OK to commit.
Tested build of both devel/qca and devel/qca-qt5 on 11.1 amd64. Testport to be run a bit later when my OpenSSL 1.1 bulk build finishes.
Comment 4 Tobias C. Berner freebsd_committer 2018-02-15 19:29:50 UTC
kde@ has an exp-run planned for the upgrade: 225929

mfg Tobias
Comment 5 Raphael Kubo da Costa freebsd_committer 2018-02-15 19:36:02 UTC
The original QCA git commit is a lot bigger than that one. Don't you need the other parts? I don't see how just including this header and not using it anywhere helps.
Comment 6 Adriaan de Groot freebsd_committer 2018-04-08 21:03:52 UTC
This got lost -- both the addition of LICENSE and the patch that adds compatibility bits -- during the exp-run and update. Brnrd, what's the status?
Comment 7 Bernard Spil freebsd_committer 2018-06-15 10:07:06 UTC
During BSDCan 2018 the intention to update OpenSSL in base to 1.1.x branch was documented.

Intention is to update 12-STABLE to current 1.1.0 and subsequently update it to 1.1.1 when that is released. The intent to update OpenSSL to 1.1 in 12 has now officially been documented in Bug #228912
Comment 8 Tobias C. Berner freebsd_committer 2018-10-20 19:36:46 UTC
Moin moin 

The update to 2.1.3 happened in r462213 and it was fixed to work with OpenSSL 1.1.1 in r481850.


mfg Tobias