Bug 225921 - devel/oniguruma (lang/php72): FreeBSD patches to oniguruma "failed to apply cleanly"
Summary: devel/oniguruma (lang/php72): FreeBSD patches to oniguruma "failed to apply ...
Status: Closed DUPLICATE of bug 226175
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: freebsd-ports-bugs (Nobody)
URL:
Keywords:
: 223663 (view as bug list)
Depends on:
Blocks:
 
Reported: 2018-02-15 15:21 UTC by MMacD
Modified: 2018-02-24 18:03 UTC (History)
4 users (show)

See Also:
bugzilla: maintainer-feedback? (tz)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description MMacD 2018-02-15 15:21:15 UTC
===> Fetching all distfiles required by php72-mbstring-7.2.2 for building
===>  Extracting for php72-mbstring-7.2.2
=> SHA256 Checksum OK for php-7.2.2.tar.xz.
===>  Patching for php72-mbstring-7.2.2
===>  Applying FreeBSD patches for php72-mbstring-7.2.2
===>   php72-mbstring-7.2.2 depends on file: /usr/local/bin/phpize - found
===>   php72-mbstring-7.2.2 depends on package: autoconf>0 - found
===>   php72-mbstring-7.2.2 depends on shared library: libonig.so - not found
===>  License BSD2CLAUSE accepted by the user
===>   oniguruma-6.7.1 depends on file: /usr/local/sbin/pkg - found
=> onig-6.7.1.tar.gz doesn't seem to exist in /usr/ports/distfiles/.
=> Attempting to fetch https://github.com/kkos/oniguruma/releases/download/v6.7.1/onig-6.7.1.tar.gz
onig-6.7.1.tar.gz                             100% of  929 kB   39 kBps 00m24s
===> Fetching all distfiles required by oniguruma-6.7.1 for building
===>  Extracting for oniguruma-6.7.1
=> SHA256 Checksum OK for onig-6.7.1.tar.gz.
===>  Patching for oniguruma-6.7.1
===>  Applying FreeBSD patches for oniguruma-6.7.1
2 out of 2 hunks failed--saving rejects to Makefile.in.rej
=> FreeBSD patch patch-Makefile.in failed to apply cleanly.
*** Error code 1

Stop.
make[5]: stopped in /usr/ports/devel/oniguruma
*** Error code 1

Stop.
make[4]: stopped in /usr/ports/devel/oniguruma
*** Error code 1

Stop.
make[3]: stopped in /usr/ports/converters/php72-mbstring
*** Error code 1

Stop.
make[2]: stopped in /usr/ports/converters/php72-mbstring
*** Error code 1

Stop.
make[1]: stopped in /usr/ports/lang/php72-extensions
*** Error code 1

Stop.
make: stopped in /usr/ports/lang/php72-extensions
                                                                                                                    10:04 Thu, 15 Feb                                                                                                   [fastcat:root]/usr/ports/lang/php72-extensions>
Comment 1 Walter Schwarzenfeld freebsd_triage 2018-02-15 21:30:28 UTC
Can't find a patch in oniguruma (?). No files directory and no patch in the port Makefile.
(except pathfix for Makefile.am).
Comment 2 Torsten Zuehlsdorff freebsd_committer 2018-02-16 08:19:10 UTC
Can you please provide some additional information? I'm unable to reproduce:

[/usr/ports/converters/php72-mbstring]$ make patch
===>  License PHP301 accepted by the user
===>   php72-mbstring-7.2.2 depends on file: /usr/local/sbin/pkg - found
===> Fetching all distfiles required by php72-mbstring-7.2.2 for building
===>  Extracting for php72-mbstring-7.2.2
=> SHA256 Checksum OK for php-7.2.2.tar.xz.
===>  Patching for php72-mbstring-7.2.2
===>  Applying FreeBSD patches for php72-mbstring-7.2.2

Same for oniguruma:

[/usr/ports/devel/oniguruma]$ make patch
===>  License BSD2CLAUSE accepted by the user
===>   oniguruma-6.7.1 depends on file: /usr/local/sbin/pkg - found
===> Fetching all distfiles required by oniguruma-6.7.1 for building
===>  Extracting for oniguruma-6.7.1
=> SHA256 Checksum OK for onig-6.7.1.tar.gz.
===>  Patching for oniguruma-6.7.1

And as Walter already stated: there is no patch in oniguruma.
Comment 3 MMacD 2018-02-16 12:25:05 UTC
I don't know what to tell you.  I didn't invent that output!  *Something* thinks there are patches for oniguruma.  I don't have any more information than that.

But I'll do a fresh build and see whether that helps.
Comment 4 Walter Schwarzenfeld freebsd_triage 2018-02-16 12:30:29 UTC

*** This bug has been marked as a duplicate of bug 223663 ***
Comment 5 Walter Schwarzenfeld freebsd_triage 2018-02-16 12:33:25 UTC
Was an error. But in Bug #223663 same problems.
Comment 6 Walter Schwarzenfeld freebsd_triage 2018-02-16 12:54:50 UTC
From the other PR:
=> portsnap fetch & portsnap update - doesn't remove outdated 'files' directory in devel/onigurima. So I've faced the same error.

Please look, if the files directory still in devel/oniguruma and if remove it.
Comment 7 Yuri Victorovich freebsd_committer 2018-02-16 17:07:56 UTC
MMacD,

You seem to have a stray /usr/ports/devel/oniguruma/files directory. Please delete it, and run "svn revert -R /usr/ports/devel/oniguruma ; svn update /usr/ports/devel/oniguruma".
Comment 8 Yuri Victorovich freebsd_committer 2018-02-24 17:58:07 UTC
*** Bug 223663 has been marked as a duplicate of this bug. ***
Comment 9 Yuri Victorovich freebsd_committer 2018-02-24 18:03:45 UTC

*** This bug has been marked as a duplicate of bug 226175 ***