Bug 225937 - devel/meson: Update to 0.44.1
Summary: devel/meson: Update to 0.44.1
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Many People
Assignee: Don Lewis
URL: https://groups.google.com/forum/#!top...
Keywords:
Depends on:
Blocks: 225895
  Show dependency treegraph
 
Reported: 2018-02-16 03:19 UTC by Carlos J. Puga Medina
Modified: 2018-02-28 04:30 UTC (History)
3 users (show)

See Also:
bugzilla: maintainer-feedback? (gnome)


Attachments
patch (2.53 KB, patch)
2018-02-16 03:19 UTC, Carlos J. Puga Medina
no flags Details | Diff
patch (2.53 KB, patch)
2018-02-18 17:39 UTC, Carlos J. Puga Medina
no flags Details | Diff
patch (901 bytes, patch)
2018-02-26 19:19 UTC, Carlos J. Puga Medina
cpm: maintainer-approval? (gnome)
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Carlos J. Puga Medina freebsd_committer 2018-02-16 03:19:08 UTC
Created attachment 190671 [details]
patch

Since upgrading to meson 0.44.0, the paths generated from a call to gnome.compile_resources include the subdirectory twice, breaking the build.

The attached patch [1] fixes the issue.

[1] https://github.com/mesonbuild/meson/issues/2860#issuecomment-355544682
Comment 1 Carlos J. Puga Medina freebsd_committer 2018-02-18 17:39:44 UTC
Created attachment 190751 [details]
patch

Cosmetic fix
Comment 2 Carlos J. Puga Medina freebsd_committer 2018-02-26 19:19:17 UTC
Created attachment 191025 [details]
patch

- Update meson to 0.44.1
Comment 3 commit-hook freebsd_committer 2018-02-28 04:28:25 UTC
A commit references this bug:

Author: truckman
Date: Wed Feb 28 04:28:08 UTC 2018
New revision: 463176
URL: https://svnweb.freebsd.org/changeset/ports/463176

Log:
  Upgrade devel/meson from 0.44.0 to 0.44.1. This is a bugfix-only
  release with no new features.  This release has 75 commits and fixes
  roughly 40 regressions, issues, and minor improvements that were
  reported in 0.44.0. For a complete list, visit:
    https://github.com/mesonbuild/meson/milestone/24?closed=1

  PR:		225937
  Submitted by:	cpm

Changes:
  head/devel/meson/Makefile
  head/devel/meson/distinfo