Bug 226029 - devel/appstream-glib fails to configure with manpages=on (typo in Makefile)
Summary: devel/appstream-glib fails to configure with manpages=on (typo in Makefile)
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Tobias Kortkamp
URL:
Keywords: easy, needs-qa
Depends on:
Blocks:
 
Reported: 2018-02-19 05:57 UTC by Walter Schwarzenfeld
Modified: 2019-10-19 06:47 UTC (History)
1 user (show)

See Also:
bugzilla: maintainer-feedback? (gnome)
koobs: merge-quarterly?


Attachments
patch-Makefile (375 bytes, patch)
2018-02-19 17:06 UTC, Walter Schwarzenfeld
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Walter Schwarzenfeld freebsd_triage 2018-02-19 05:57:48 UTC
Fails with MANPAGES=ON with:
checking for DocBook XSL Stylesheets in XML catalog... not found
configure: error: manpage generation requested but required utilities were not found
===>  Script "configure" failed unexpectedly.
Please report the problem to gnome@FreeBSD.org [maintainer] and attach the
"/ram/usr/ports/devel/appstream-glib/work/appstream-glib-0.5.7/config.log"
including the output of the failure of your make command. Also, it might be
a good idea to provide an overview of all packages installed on your system
(e.g. a /usr/local/sbin/pkg-static info -g -Ea).
*** Error code 1

Stop.
make[1]: stopped in /usr/ports/devel/appstream-glib
*** Error code 1
Comment 1 Walter Schwarzenfeld freebsd_triage 2018-02-19 12:43:04 UTC
It configures and build if I set
CONFIGURE_ARGS= --with-xml-catalog=${LOCALBASE}/share/xml/catalog && /usr/local/share/xml/docbook/4.3/catalog.xml \

but:
Package appstream-glib was not found in the pkg-config search path.
Perhaps you should add the directory containing `appstream-glib.pc'
to the PKG_CONFIG_PATH environment variable
Package 'appstream-glib', required by 'virtual:world', not found


and 
install:
kg-static: Unable to access file /ram/usr/ports/devel/appstream-glib/work/stage/usr/local/man/man1/appstream-builder.1.gz:No such file or directory
pkg-static: Unable to access file /ram/usr/ports/devel/appstream-glib/work/stage/usr/local/man/man1/appstream-compose.1.gz:No such file or directory
pkg-static: Unable to access file /ram/usr/ports/devel/appstream-glib/work/stage/usr/local/man/man1/appstream-util.1.gz:No such file or directory
*** Error code 74
Comment 2 Walter Schwarzenfeld freebsd_triage 2018-02-19 15:32:44 UTC
I found new version 0.7.6. (But this is a "meson-thing".
Comment 3 Walter Schwarzenfeld freebsd_triage 2018-02-19 16:47:41 UTC
The cause was simple and a mean one:

MANPAGE_BUILD_DEPENDS=....
      ^ 
should be
MANPAGES_BUILD_DEPENDS=....
Comment 4 Walter Schwarzenfeld freebsd_triage 2018-02-19 17:06:52 UTC
Created attachment 190809 [details]
patch-Makefile
Comment 6 Tobias Kortkamp freebsd_committer 2018-03-11 10:12:07 UTC
This seems to build fine with MANPAGES=on:

http://beefy9.nyi.freebsd.org/data/111amd64-default/463855/logs/appstream-glib-0.5.7.log

I suspect that there is some option combination in dependent ports that
causes the problem on your system.

No point in investigating though since the typo seems obvious so I'll just
land the fix with a maintainer timeout.
Comment 7 Tobias Kortkamp freebsd_committer 2018-03-11 10:12:40 UTC
Committed. Thanks!
Comment 8 commit-hook freebsd_committer 2018-03-11 10:12:40 UTC
A commit references this bug:

Author: tobik
Date: Sun Mar 11 10:12:29 UTC 2018
New revision: 464160
URL: https://svnweb.freebsd.org/changeset/ports/464160

Log:
  devel/appstream-glib: Fix typo

  MANPAGE_BUILD_DEPENDS -> MANPAGES_BUILD_DEPENDS

  Depending on option selection in dependent ports docbook-{xsl,xml}
  might not be installed in the build environment and building with
  MANPAGES=on would fail to configure.

  PR:		226029
  Submitted by:	w.schwarzenfeld@utanet.at
  Approved by:	gnome (maintainer timeout, 2 weeks+)

Changes:
  head/devel/appstream-glib/Makefile
Comment 9 Walter Schwarzenfeld freebsd_triage 2018-03-11 11:01:14 UTC
The "strange" thing was: Poudriere does build it, with the typo. It only fails with the port.
Comment 10 commit-hook freebsd_committer 2019-10-19 06:47:03 UTC
A commit references this bug:

Author: tobik
Date: Sat Oct 19 06:46:12 UTC 2019
New revision: 514758
URL: https://svnweb.freebsd.org/changeset/ports/514758

Log:
  devel/appstream-glib: Spell MANPAGES_BUILD_DEPENDS correctly again

  Regressed in r480951.

  PR:		226029

Changes:
  head/devel/appstream-glib/Makefile