Bug 226177 - irc/netwalker-ircc: fails to build on 12.0 after 1200056
Summary: irc/netwalker-ircc: fails to build on 12.0 after 1200056
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: freebsd-ports-bugs mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-02-24 18:46 UTC by Emanuel Haupt
Modified: 2018-11-04 10:47 UTC (History)
2 users (show)

See Also:


Attachments
Build failure with clang 6.0.0 on 12.0 (18.48 KB, text/plain)
2018-02-24 18:46 UTC, Emanuel Haupt
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Emanuel Haupt freebsd_committer 2018-02-24 18:46:47 UTC
Created attachment 190962 [details]
Build failure with clang 6.0.0 on 12.0

irc/netwalker-ircc fails to build on 12.0 with clang 6.0.0
Comment 1 Gerald Pfeifer freebsd_committer 2018-08-04 10:49:32 UTC
Emanuel has marked this port for deprecation and moved to ports@ for
maintainership.  (I only got assigned originally since I had suggested
to create a PR for every new instance of USE_GCC to cover for breakage
caused by newer versions of clang.9
Comment 2 commit-hook freebsd_committer 2018-08-04 10:57:06 UTC
A commit references this bug:

Author: gerald
Date: Sat Aug  4 10:56:57 UTC 2018
New revision: 476347
URL: https://svnweb.freebsd.org/changeset/ports/476347

Log:
  Add references to PR 226177 which tracks the breakage of this port by
  clang 6.0.0.

  PR:		226177

Changes:
  head/irc/netwalker-ircc/Makefile
Comment 3 Rene Ladan freebsd_committer 2018-11-04 10:47:36 UTC
Expired port removed.