Bug 226200 - shells/bash libdl.so.1 not found
Summary: shells/bash libdl.so.1 not found
Status: Closed Unable to Reproduce
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: amd64 Any
: --- Affects Many People
Assignee: Emanuel Haupt
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-02-25 16:07 UTC by Dr. Andreas Haakh
Modified: 2018-11-17 09:31 UTC (History)
1 user (show)

See Also:
bugzilla: maintainer-feedback? (ehaupt)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dr. Andreas Haakh 2018-02-25 16:07:09 UTC
Due to the above error, bash-4.4.19 from pkg will not start on 
ah@xxxxxx:~ % uname -a
FreeBSD xxxxxx.haakh.de 12.0-CURRENT FreeBSD 12.0-CURRENT #0 r326622: Wed Dec  6 16:09:07 CET 2017     toor@xxxxxx.haakh.de:/usr/obj/usr/src/amd64.amd64/sys/GENERIC  amd64

ah@xxxxxx:~ %  bash
Shared object "libdl.so.1" not found, required by "bash"
ah@xxxxxx:~ % ldd /usr/local/bin/bash
/usr/local/bin/bash:
        libncurses.so.8 => /lib/libncurses.so.8 (0x80092a000)
        libintl.so.8 => /usr/local/lib/libintl.so.8 (0x800b7f000)
        libdl.so.1 => not found (0)
        libc.so.7 => /lib/libc.so.7 (0x800d8a000)
ah@xxxxxx:~ % 

Fix
Comment 1 Emanuel Haupt freebsd_committer 2018-02-25 16:27:49 UTC
It looks like the bash binary on your system is missing libdl.so.1. I'm taking a guess that the package you've installed was built on a 12.0-CURRENT newer than r326622 (which you're using).

Could you try updating your system to a more recent 12.0-CURRENT and reinstall bash (including dependencies)?

# pkg upgrade -f
Comment 2 Dr. Andreas Haakh 2018-03-06 07:42:23 UTC
I just updated to 12.0-CURRENT as of Feb 26th (revision 329987) and libdl.so.1 appeared in /usr/lib
Thanks for your help and please close the PR.
Comment 3 Manikandan Arumugam 2018-11-17 08:56:48 UTC
Im saving the same issue, can you please help to resolve this.

Unable to login via root user to update the pkg.
Comment 4 Emanuel Haupt freebsd_committer 2018-11-17 09:31:07 UTC
The FreeBSD 'questions' mailing list would be a more suitable place ask your question. Please refer to:

https://www.freebsd.org/doc/en_US.ISO8859-1/books/handbook/eresources-mail.html