Bug 226216 - devel/pear: port uses outdated go-pear bundle
Summary: devel/pear: port uses outdated go-pear bundle
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Many People
Assignee: Jochen Neumeister
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-02-26 10:49 UTC by Michael Osipov
Modified: 2018-11-23 17:35 UTC (History)
1 user (show)

See Also:
bugzilla: maintainer-feedback? (joneum)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Michael Osipov 2018-02-26 10:49:56 UTC
Looking at the Makefile it uses a pre-bundled go-pear distro. The included go-pear.php is outdated if compared to https://pear.php.net/go-pear. The bundled libraries are outdated too. Using https://pear.php.net/go-pear points to https://pear.php.net/go-pear.phar which is the new, shiny installer.

The new installer also fixes the PHP 7.2 Archive_Tar issue: https://github.com/pear/pearweb_phars/issues/2

Consider using "fetch https://pear.php.net/go-pear.phar". This script provides env variables to customize all installation paths.

Unfortunately, this script is interactive and not really suited for the Ports system. I would not patch it, but rather request an upstream change first.
Comment 1 Michael Osipov 2018-02-26 11:01:55 UTC
I have requested a non-interactive mode upstream: https://github.com/pear/pearweb_phars/issues/4
Comment 2 Jochen Neumeister freebsd_committer 2018-03-08 19:40:42 UTC
There are only 2 old bundle:
Archive_Tar ans XML_Util.
Port will update this weekend.
Comment 3 Michael Osipov 2018-03-08 21:12:56 UTC
(In reply to Jochen Neumeister from comment #2)

Will you update the PEAR module itself too or just those two deps?
Comment 4 Michael Osipov 2018-06-12 21:57:38 UTC
(In reply to Michael Osipov from comment #3)

Can I help somehow to resolve this?
Comment 5 Michael Osipov 2018-09-12 20:10:47 UTC
Any news?
Comment 6 Jochen Neumeister freebsd_committer 2018-10-31 17:09:37 UTC
The problem is just the go-pear version 1.1.7
I have now spent 2 days trying to update this version with the "patch-go-pear" patch. Unfortunately, without success.
The pear update to 1.10.6 is ready. I will now try for a few days to fix the problem. If not, I will release version 1.10.6 with new "Archive_Tar" and "XML_Util". Unfortunately then with old go-pear version
Comment 7 Michael Osipov 2018-11-01 11:46:06 UTC
(In reply to Jochen Neumeister from comment #6)

Thanks for your effort. Where did you get 1.1.7? This (https://github.com/pear/pearweb/blob/master/public_html/go-pear#L56) shows me 1.1.6 which is probably fine for us.
Comment 8 Jochen Neumeister freebsd_committer 2018-11-02 16:39:01 UTC
(In reply to Michael Osipov from comment #7)

i get it frome here: https://pear.php.net/package/pearweb_gopear - and have a lot of problems
Comment 9 Michael Osipov 2018-11-14 12:43:22 UTC
(In reply to Jochen Neumeister from comment #8)

Jochen,

do you think we can schedule a session via IRC? I'd like to help you to get this updated.
Comment 10 Jochen Neumeister freebsd_committer 2018-11-22 20:14:50 UTC
(In reply to Michael Osipov from comment #9)

Michael, of course! I'm on IRC 24/7. I did not forget the problem. You can ping me on IRC
Comment 11 Jochen Neumeister freebsd_committer 2018-11-22 20:20:46 UTC
I think I will update devel/pear in 2 steps:

- Update to 1.10.6 (including Archive_Tar and XML_Util)
- Update of the go-pear script incl. Patch.

The problem is the "newer" go-pear script, it causes a lot of problems with a patch on FreeBSD. It will take a lot of time.
Comment 12 commit-hook freebsd_committer 2018-11-23 17:22:04 UTC
A commit references this bug:

Author: joneum
Date: Fri Nov 23 17:21:15 UTC 2018
New revision: 485692
URL: https://svnweb.freebsd.org/changeset/ports/485692

Log:
  Update to 1.10.6

  Changelog:
  Update pear to 1.10.6
   * Fix notice undefined variable metadata_dir
   * fix Warning: count(): Parameter must be an array or an object
   * Remove is_executable check
   * The is_executable check in the Which method when run on Windows is unnecessary
   * Migrate old while(list() = each()) constructs to foreach
   * Fix PHP Warning: "continue" targeting switch is equivalent to "break"
   * proxy server auth
   * Correctly authenticate at proxy server
   * array or Countable error in 7.2

  Update Archive_Tar to 1.4.3
   * Cannot use result of built-in function in write context in PHP 7.2.0alpha1

  Update XML_Util to 1.4.3
   * Decrease minimum PEAR version to 1.9.0 to allow PEAR upgrades

  PR:		226216
  Sponsored by:	Netzkommune GmbH

Changes:
  head/devel/pear/Makefile
  head/devel/pear/distinfo