Bug 226220 - devel/efl: update to 1.20.6
Summary: devel/efl: update to 1.20.6
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: Yuri Victorovich
URL:
Keywords: patch-ready
Depends on:
Blocks:
 
Reported: 2018-02-26 17:07 UTC by lbartoletti
Modified: 2018-07-08 22:31 UTC (History)
2 users (show)

See Also:
bugzilla: maintainer-feedback? (enlightenment)


Attachments
efl 1.20.6 (49.37 KB, patch)
2018-02-26 17:08 UTC, lbartoletti
no flags Details | Diff
efl-1_20_7.patch (57.46 KB, patch)
2018-03-12 00:12 UTC, Greg V
no flags Details | Diff
efl-1_20_7.patch (58.03 KB, patch)
2018-03-12 00:14 UTC, Greg V
no flags Details | Diff
current-patch (55.63 KB, patch)
2018-03-19 22:35 UTC, Yuri Victorovich
no flags Details | Diff
current-patch (55.68 KB, patch)
2018-03-20 02:27 UTC, Yuri Victorovich
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description lbartoletti 2018-02-26 17:07:27 UTC
Update efl to 1.20.6
with some minor changes in the Makefile

--
Poudriere 10/11 i386/amd64 OK
Portlint OK
Comment 1 lbartoletti 2018-02-26 17:08:01 UTC
Created attachment 191022 [details]
efl 1.20.6
Comment 2 Greg V 2018-03-12 00:12:04 UTC
Created attachment 191437 [details]
efl-1_20_7.patch

Here's 1.20.7 with Wayland support options added.

Tested `ELM_DISPLAY=wl ELM_ACCEL=opengl terminology` under Weston, the terminal does work.
Comment 3 Greg V 2018-03-12 00:14:35 UTC
Created attachment 191438 [details]
efl-1_20_7.patch

oops, git ate a new file
Comment 4 Yuri Victorovich freebsd_committer 2018-03-19 07:04:47 UTC
Maintainer's timeout expired: enlightenment@FreeBSD.org
Comment 5 Yuri Victorovich freebsd_committer 2018-03-19 22:35:00 UTC
This port suffers from several problems after the update. Problems may have existed before.

1. When all options are "off", stage-qa failed. I fixed this by adding %%OPENGL%% to 2 files in pkg-plist and by adding an extra step to post-install deleting an empty directory.

2. When OPENGLES is selected, build fails.
> configure: error: OpenGL ES requires EGL, please add --enable-egl to your configure options to switch to EGL + OpenGL ES.

This one is still an issue.

Attaching my my current version.
Comment 6 Yuri Victorovich freebsd_committer 2018-03-19 22:35:39 UTC
Created attachment 191649 [details]
current-patch
Comment 7 Yuri Victorovich freebsd_committer 2018-03-20 02:27:30 UTC
Created attachment 191655 [details]
current-patch

I solved all previous problems. Now the new option WAYLAND doesn't work.
When I build all options by default plus WAYLAND=on, it breaks:
> configure: error: in `/usr/ports/devel/efl/work/efl-1.20.7':
> configure: error: C compiler cannot create executables
> See `config.log' for more details
> ===>  Script "configure" failed unexpectedly.
Comment 8 Greg V 2018-03-21 23:09:24 UTC
(In reply to Yuri Victorovich from comment #7)
huh, weird. I can't reproduce that error.
Comment 9 Yuri Victorovich freebsd_committer 2018-07-08 22:30:36 UTC
Committed.
Thank you for your submission!
Comment 10 commit-hook freebsd_committer 2018-07-08 22:31:33 UTC
A commit references this bug:

Author: yuri
Date: Sun Jul  8 22:30:31 UTC 2018
New revision: 474206
URL: https://svnweb.freebsd.org/changeset/ports/474206

Log:
  devel/efl: Update 1.19.2 -> 1.20.7

  Port changes:
  * Change to DISTVERSION
  * Add to LIB_DEPENDS and USE_XORG
  * Update CONFIGURE_ARGS
  * Add INSTALLS_ICONS
  * Add options WAYLAND WAYLAND_EGL (broken due to a bug reported upstream)
  * Add option OPENGLES
  * Make PULSEAUDIO a default
  * Silence some commands in post-install
  * Remove an empty directory

  PR:		226220
  Submitted by:	lbartoletti <lbartoletti@tuxfamily.org>

Changes:
  head/devel/efl/Makefile
  head/devel/efl/distinfo
  head/devel/efl/files/patch-src_Makefile.am
  head/devel/efl/pkg-plist