Bug 226328 - net/isc-dhcp44-server rc.d script doest not get "paranoia=%%PARANOIAOPT%%" substituted correctly
Summary: net/isc-dhcp44-server rc.d script doest not get "paranoia=%%PARANOIAOPT%%" su...
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: amd64 Any
: --- Affects Only Me
Assignee: Ryan Steinmetz
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-03-03 16:27 UTC by Dries Michiels
Modified: 2018-03-03 17:53 UTC (History)
1 user (show)

See Also:
bugzilla: maintainer-feedback? (zi)


Attachments
installed rc.d script (62.32 KB, image/png)
2018-03-03 16:27 UTC, Dries Michiels
no flags Details
installing isc-dhcp44-server (113.80 KB, image/png)
2018-03-03 16:29 UTC, Dries Michiels
no flags Details
init script patched to reflect revised paranoia opt. string. (548 bytes, patch)
2018-03-03 17:07 UTC, Chip Cuccio
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Dries Michiels freebsd_committer 2018-03-03 16:27:10 UTC
Created attachment 191174 [details]
installed rc.d script

When installing isc-dhcp44-server, the installed rc.d script still contains: paranoia=%%PARANOIAOPT%% instead of paranoia=yes See attached snips.
Comment 1 Dries Michiels freebsd_committer 2018-03-03 16:29:08 UTC
Created attachment 191175 [details]
installing isc-dhcp44-server
Comment 2 Dries Michiels freebsd_committer 2018-03-03 16:32:04 UTC
Just noticed, also this line;

eval ": \${${name}_chuser_enable:=\"\"}"

should be 

eval ": \${${name}_chuser_enable:=\"yes\"}"
Comment 3 Chip Cuccio 2018-03-03 16:44:29 UTC
I can reproduce this issue on two machines, amd64 and powerpc

Unable to try and patch it today/this weekend due to family stuffs. Perhaps @Zi will get to it before I can take a crack at it.
Comment 4 commit-hook freebsd_committer 2018-03-03 16:50:14 UTC
A commit references this bug:

Author: zi
Date: Sat Mar  3 16:50:06 UTC 2018
New revision: 463515
URL: https://svnweb.freebsd.org/changeset/ports/463515

Log:
  - Fix more logic issues after OPTIONS edits

  PR:		226328

Changes:
  head/net/isc-dhcp44-server/Makefile
Comment 5 Chip Cuccio 2018-03-03 17:07:55 UTC
Created attachment 191176 [details]
init script patched to reflect revised paranoia opt. string.

Patched isc-dhcpd.in attached for paranoia opt. revised string name.
Comment 6 Chip Cuccio 2018-03-03 17:22:42 UTC
(In reply to Chip Cuccio from comment #5)

[ this is to compliment commit 463515 where @Ryan/zi graciously fixe the makefile :-) ]
Comment 7 Dries Michiels freebsd_committer 2018-03-03 17:34:51 UTC
Lovely! I see zi commited your patch at r463517.
Thanks Ryan! Thanks Chip!
Comment 8 Chip Cuccio 2018-03-03 17:53:06 UTC
(In reply to Duffyx from comment #7)

Thanks for reporting it Duffyx!
Cheers.