Bug 226371 - sysutils/synergy now needs c++14
Summary: sysutils/synergy now needs c++14
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Yuri Victorovich
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-03-05 17:52 UTC by Justin Hibbits
Modified: 2018-03-05 20:55 UTC (History)
0 users

See Also:
bugzilla: maintainer-feedback? (yuri)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Justin Hibbits freebsd_committer 2018-03-05 17:52:44 UTC
Building sysutils/synergy on powerpc I see an error from cmake:

Target "core" requires the language dialect "CXX14", but CMake does not know the compiler flags to use to enable it.

with "core" replaced by all targets individually.
Comment 1 Yuri Victorovich freebsd_committer 2018-03-05 18:52:34 UTC
Could you please confirm that adding compiler:c++14-lang to USES resolves this for you?
Comment 2 Justin Hibbits freebsd_committer 2018-03-05 20:43:15 UTC
I just confirmed, adding "compiler:c++14-lang" to the USES list lets it build correctly.
Comment 3 commit-hook freebsd_committer 2018-03-05 20:54:56 UTC
A commit references this bug:

Author: yuri
Date: Mon Mar  5 20:54:53 UTC 2018
New revision: 463668
URL: https://svnweb.freebsd.org/changeset/ports/463668

Log:
  sysutils/synergy: Add USES=compiler:c++14-lang because powerpc build was failing without it

  PR:		226371
  Reported by:	jhibbits
  Approved by:	tcberner (mentor, implicit)

Changes:
  head/sysutils/synergy/Makefile
Comment 4 Yuri Victorovich freebsd_committer 2018-03-05 20:55:21 UTC
Thank you for confirming.

Committed.