Bug 226383 - dns/bind911: Enable filter-on-aaaa-v4 and filter-on-aaaa-v6 support
Summary: dns/bind911: Enable filter-on-aaaa-v4 and filter-on-aaaa-v6 support
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: Mathieu Arnold
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-03-06 01:17 UTC by Jeremy Chadwick
Modified: 2018-03-22 14:13 UTC (History)
0 users

See Also:
bugzilla: maintainer-feedback? (mat)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jeremy Chadwick 2018-03-06 01:17:13 UTC
The options {} directives filter-aaaa-on-v4 and filter-aaaa-on-v6 do not work if used:

/usr/local/etc/namedb/named.conf:25: option 'filter-aaaa-on-v4' was not enabled at compile time

I've confirmed this with dns/bind911 (pkg bind911-9.11.2P1_3) on stable/11, but  would apply to dns/bind99, dns/bind910, dns/bind912, and dns/bind9-devel too.

Can this feature please be enabled via configure --enable-filter-aaaa ?  This configure flag only enables the directives themselves; the run-time values default to "no" (i.e. no operational change).

Reference: https://kb.isc.org/article/AA-00576/0/Filter-AAAA-option-in-BIND-9-.html

Thank you.
Comment 1 Mathieu Arnold freebsd_committer 2018-03-06 16:55:10 UTC
There already are options to enable those features.
Comment 2 Jeremy Chadwick 2018-03-06 17:26:43 UTC
Yes, if you're using ports.  If you're using a package, there isn't, because the feature must be enabled at configure/compile-time.

Please advise.
Comment 3 commit-hook freebsd_committer 2018-03-22 14:13:53 UTC
A commit references this bug:

Author: mat
Date: Thu Mar 22 14:13:02 UTC 2018
New revision: 465288
URL: https://svnweb.freebsd.org/changeset/ports/465288

Log:
  Enable the FILTER_AAAA option by default, the feature was made non
  optional in recent versions, so might as well do it in older ones.

  PR:		226383
  Sponsored by:	Absolight

Changes:
  head/dns/bind910/Makefile
  head/dns/bind911/Makefile
  head/dns/bind99/Makefile