Bug 226408 - graphics/wayland-protocols: update to 1.16
Summary: graphics/wayland-protocols: update to 1.16
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Jan Beich
URL:
Keywords:
: 230652 (view as bug list)
Depends on:
Blocks:
 
Reported: 2018-03-06 21:15 UTC by Greg V
Modified: 2018-10-16 00:10 UTC (History)
3 users (show)

See Also:
bugzilla: maintainer-feedback? (kwm)


Attachments
wayland-protocols-1.13.patch (1.71 KB, patch)
2018-03-06 21:15 UTC, Greg V
no flags Details | Diff
wayland-protocols-1.16.patch (2.24 KB, patch)
2018-10-12 21:51 UTC, Greg V
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Greg V 2018-03-06 21:15:45 UTC
Created attachment 191266 [details]
wayland-protocols-1.13.patch

This version is now required by weston git master.
Comment 1 Greg V 2018-10-12 21:51:32 UTC
Created attachment 198075 [details]
wayland-protocols-1.16.patch

Update to 1.16
Comment 2 Jan Beich freebsd_committer 2018-10-15 19:53:43 UTC
*** Bug 230652 has been marked as a duplicate of this bug. ***
Comment 3 Jan Beich freebsd_committer 2018-10-15 19:58:23 UTC
Required by mpv since 0.29.1 (aka ports r481467), see https://github.com/mpv-player/mpv/commit/d82888779237

$ make WITH=WAYLAND -C/usr/ports/multimedia/mpv
Checking for wayland-scanner                                      : yes
Checking for wayland-protocols                                    : no ('wayland-protocols >= 1.14' not found)
Checking for Wayland                                              : wayland-protocols not found
Checking for OpenGL Wayland Backend                               : wayland not found
Checking for VAAPI (Wayland support)                              : gl-wayland not found
You manually enabled the feature 'vaapi-wayland', but the autodetection check failed.
===>  Script "configure" failed unexpectedly.

-----------------------------------------------------------------
Checking for wayland-protocols
['pkgconf', 'wayland-protocols >= 1.14', '--variable=pkgdatadir', 'wayland-protocols']
from /tmp/a/overlay/git-ports/multimedia/mpv/work/mpv-0.29.1: The configuration failed
no ('wayland-protocols >= 1.14' not found)
-----------------------------------------------------------------
Checking for Wayland
wayland-protocols not found
Comment 4 Jan Beich freebsd_committer 2018-10-15 20:01:05 UTC
Err, mpv since 0.29.0, not 0.29.1.

$ git describe --contains --tags d82888779237
v0.29.0~64
Comment 5 commit-hook freebsd_committer 2018-10-16 00:01:27 UTC
A commit references this bug:

Author: jbeich
Date: Tue Oct 16 00:00:34 UTC 2018
New revision: 482193
URL: https://svnweb.freebsd.org/changeset/ports/482193

Log:
  graphics/wayland-protocols: update to 1.16

  Changes:	https://cgit.freedesktop.org/wayland/wayland-protocols/log/?h=1.16
  PR:		226408
  Submitted by:	Greg V
  Approved by:	maintainer timeout (2 months via bug 230652)

Changes:
  head/graphics/wayland-protocols/Makefile
  head/graphics/wayland-protocols/distinfo
  head/graphics/wayland-protocols/pkg-plist
  head/multimedia/mpv/Makefile