Bug 226423 - amd64 kernel build fails with errors in /usr/src/sys/netipsec/xform_ah.c
Summary: amd64 kernel build fails with errors in /usr/src/sys/netipsec/xform_ah.c
Status: Closed FIXED
Alias: None
Product: Base System
Classification: Unclassified
Component: kern (show other bugs)
Version: 10.4-RELEASE
Hardware: amd64 Any
: --- Affects Only Me
Assignee: freebsd-bugs (Nobody)
URL:
Keywords:
: 226428 (view as bug list)
Depends on:
Blocks:
 
Reported: 2018-03-07 16:10 UTC by kudzu
Modified: 2018-03-08 14:52 UTC (History)
2 users (show)

See Also:


Attachments
make kernel output (605.97 KB, text/plain)
2018-03-07 16:10 UTC, kudzu
no flags Details
kernconf (6.54 KB, text/plain)
2018-03-07 16:21 UTC, kudzu
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description kudzu 2018-03-07 16:10:29 UTC
Created attachment 191282 [details]
make kernel output

Updated sources via freebsd-update subsequent to 

FreeBSD-SA-18:01.ipsec

Cause kernel compile to fail.

make output attached, summary follows:


##########################################################

cc  -c -O2 -pipe -fno-strict-aliasing  -std=c99  -Wall -Wredundant-decls -Wnested-externs -Wstrict-prototypes  -Wmissing-prototypes -Wpointer-arith -Winline -Wcast-qual  -Wundef -Wno-pointer-sign -fformat-extensions  -Wmissing-include-dirs -fdiagnostics-show-option  -Wno-error-tautological-compare -Wno-error-empty-body  -Wno-error-parentheses-equality -Wno-error-unused-function   -nostdinc  -I. -I/usr/src/sys -I/usr/src/sys/contrib/altq -I/usr/src/sys/contrib/libfdt -D_KERNEL -DHAVE_KERNEL_OPTION_HEADERS -include opt_global.h  -fno-omit-frame-pointer -mno-omit-leaf-frame-pointer -mno-aes -mno-avx -mcmodel=kernel -mno-red-zone -mno-mmx -mno-sse -msoft-float  -fno-asynchronous-unwind-tables -ffreestanding -fstack-protector -Werror  /usr/src/sys/netipsec/xform_ah.c
/usr/src/sys/netipsec/xform_ah.c:622:43: error: use of undeclared identifier 'buf'
                    ipsec_address(&sav->sah->saidx.dst, buf, sizeof(buf)),
                                                        ^
/usr/src/sys/netipsec/ipsec.h:323:51: note: expanded from macro 'DPRINTF'
#define DPRINTF(x)      do { if (V_ipsec_debug) printf x; } while (0)
                                                       ^
/usr/src/sys/netipsec/xform_ah.c:625:3: error: use of undeclared identifier 'error'
                error = EACCES;
                ^
/usr/src/sys/netipsec/xform_ah.c:626:8: error: use of undeclared label 'bad'
                goto bad;
                     ^
3 errors generated.
*** Error code 1
Comment 1 kudzu 2018-03-07 16:21:24 UTC
Created attachment 191283 [details]
kernconf
Comment 2 Conrad Meyer freebsd_committer 2018-03-07 18:56:39 UTC
*** Bug 226428 has been marked as a duplicate of this bug. ***
Comment 3 kudzu 2018-03-08 06:49:50 UTC
"v1.1  2018-03-08 Correct patch for 10.x releases" completely resolves this issue
Comment 4 Ed Maste freebsd_committer 2018-03-08 14:52:15 UTC
kudzu thank you for confirming that the updated advisory fixes the issue.