Bug 226443 - net-p2p/deluge-cli: fix preferences on a Thin Client setup
Summary: net-p2p/deluge-cli: fix preferences on a Thin Client setup
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: Ruslan Makhmatkhanov
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-03-08 07:14 UTC by Rainbow
Modified: 2018-03-14 15:52 UTC (History)
2 users (show)

See Also:
bugzilla: maintainer-feedback? (rm)


Attachments
deluge 1.3.15 preferences.py patch (605 bytes, text/plain)
2018-03-08 07:14 UTC, Rainbow
no flags Details
deluge 1.3.15 preferences.py patch (fixed) (604 bytes, patch)
2018-03-08 17:18 UTC, Rainbow
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Rainbow 2018-03-08 07:14:43 UTC
Created attachment 191300 [details]
deluge 1.3.15 preferences.py patch

Deluge 1.3.15 has a bug that was meant to be fixed but wasn't.
This bug causes Preferences on a Thin Client setup (local installation of net-p2p/deluge talking to a remote instance of net-p2p/deluge-cli) to have all preferences greyed out in the thin client. Attempting to make any changes to non-greyed out preferences (like plugin options), will cause a broken config to be written to core.conf on the remote system, and will crash the remote daemon.

The issue is detailed on their bug tracker here:
http://dev.deluge-torrent.org/ticket/3039

The official diff in the deluge source tree is here:
http://dev.deluge-torrent.org/changeset/38d7b7cdfde3c50d

Generated patch (via make makepatch) is attached.

The file that should end up modified, once the fix is installed, is
/usr/local/lib/python2.7/site-packages/deluge/ui/gtkui/preferences.py

Deluge does not have a timeline available and visible for releasing 1.3.16, and while mention of 1.3.15.1 was brought up in the bug report, no such tarball was released.

This bug is confirmed to exist in the currently available 1.3.15 release tarball.

I applied the fix in question to my own system and it resolved the issue.
Comment 1 martin.mato 2018-03-08 09:02:54 UTC
Greetings
The proposed patch contains typo error at line 11:
lt_single_proxy = Talse

it's most certainly: 
lt_single_proxy = True
Comment 2 Rainbow 2018-03-08 17:18:33 UTC
Created attachment 191315 [details]
deluge 1.3.15 preferences.py patch (fixed)

This is why you don't drink and...uh....hack?
I got so focused on writing the body of the bug report I forgot to finish filling out the title, and evidently only changed a single letter for the patch.
(In my defense, it was also well past midnight.)

Please find attached the fixed patch.
Comment 3 commit-hook freebsd_committer 2018-03-13 20:44:54 UTC
A commit references this bug:

Author: rm
Date: Tue Mar 13 20:44:19 UTC 2018
New revision: 464430
URL: https://svnweb.freebsd.org/changeset/ports/464430

Log:
  net-p2p/deluge-cli: fix runtime

  Add upstream patch to fix bug with opening preferences window.
  This patch closing https://dev.deluge-torrent.org/ticket/3039

  PR:		226443
  Submitted by:	Rainbow <rainbow@sanitylinux.org>
  MFH:		2018Q1

Changes:
  head/net-p2p/deluge-cli/Makefile
  head/net-p2p/deluge-cli/files/patch-deluge_ui_gtkui_preferences.py
Comment 4 Ruslan Makhmatkhanov freebsd_committer 2018-03-13 20:45:16 UTC
Committed, thank you!
Comment 5 commit-hook freebsd_committer 2018-03-14 15:52:59 UTC
A commit references this bug:

Author: rm
Date: Wed Mar 14 15:52:03 UTC 2018
New revision: 464506
URL: https://svnweb.freebsd.org/changeset/ports/464506

Log:
  MFH: r464430

  net-p2p/deluge-cli: fix runtime

  Add upstream patch to fix bug with opening preferences window.
  This patch closing https://dev.deluge-torrent.org/ticket/3039

  PR:		226443
  Submitted by:	Rainbow <rainbow@sanitylinux.org>

  Approved by:	ports-secteam (swills)

Changes:
_U  branches/2018Q1/
  branches/2018Q1/net-p2p/deluge-cli/Makefile
  branches/2018Q1/net-p2p/deluge-cli/files/patch-deluge_ui_gtkui_preferences.py