Bug 226548 - Upgrade of www/py-tornado to version 5.0 breaks sysutils/py-salt
Summary: Upgrade of www/py-tornado to version 5.0 breaks sysutils/py-salt
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Many People
Assignee: Grzegorz Blach
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-03-12 07:29 UTC by Matthew Leach
Modified: 2018-03-23 07:52 UTC (History)
7 users (show)

See Also:
christer.edwards: maintainer-feedback+


Attachments
Use www/tornado4 in dependency (693 bytes, patch)
2018-03-13 16:57 UTC, Grzegorz Blach
koobs: maintainer-approval+
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Matthew Leach 2018-03-12 07:29:59 UTC
Traceback (most recent call last):
  File "/usr/local/bin/salt-minion", line 6, in <module>
    from pkg_resources import load_entry_point
  File "/usr/local/lib/python2.7/site-packages/pkg_resources/__init__.py", line 3195, in <module>
    @_call_aside
  File "/usr/local/lib/python2.7/site-packages/pkg_resources/__init__.py", line 3179, in _call_aside
    f(*args, **kwargs)
  File "/usr/local/lib/python2.7/site-packages/pkg_resources/__init__.py", line 3208, in _initialize_master_working_set
    working_set = WorkingSet._build_master()
  File "/usr/local/lib/python2.7/site-packages/pkg_resources/__init__.py", line 683, in _build_master
    return cls._build_from_requirements(__requires__)
  File "/usr/local/lib/python2.7/site-packages/pkg_resources/__init__.py", line 696, in _build_from_requirements
    dists = ws.resolve(reqs, Environment())
  File "/usr/local/lib/python2.7/site-packages/pkg_resources/__init__.py", line 885, in resolve
    raise DistributionNotFound(req, requirers)
pkg_resources.DistributionNotFound: The 'tornado<5.0,>=4.2.1' distribution was not found and is required by salt
Comment 1 akuz84 2018-03-12 09:48:54 UTC
Hello.
SaltStack doesn't support tornado >= 5.0 yet.
I think right decision is to lock tornado version via pkg lock.
Comment 2 Johan Ström 2018-03-13 06:23:09 UTC
Same problem here.

Even with pkg lock, how would I go about to get tornado 4.2.1 installed when my local poudriere only has 5.0 (since it cleaned out old packages)? Perhaps it would make sense to add a tornado4 port?

Is it at all possible to use virtalenv for FreeBSD python ports?
Comment 3 Grzegorz Blach freebsd_committer 2018-03-13 16:57:35 UTC
Created attachment 191469 [details]
Use www/tornado4 in dependency
Comment 4 Craig Leres freebsd_committer 2018-03-17 01:07:40 UTC
We ran into this, found this PR and I can confirm that the patch works (now that www/py-tornado4 exists).
Comment 5 Craig Leres freebsd_committer 2018-03-17 01:12:19 UTC
(Also: I'm happy to commit this with maintainer approval.)
Comment 6 Christer Edwards 2018-03-17 05:37:43 UTC
Cheers for the patch. Approved.
Comment 7 Christer Edwards 2018-03-17 17:47:22 UTC
Comment on attachment 191469 [details]
Use www/tornado4 in dependency

+1
Comment 8 commit-hook freebsd_committer 2018-03-18 10:45:22 UTC
A commit references this bug:

Author: gblach
Date: Sun Mar 18 10:45:04 UTC 2018
New revision: 464891
URL: https://svnweb.freebsd.org/changeset/ports/464891

Log:
  Depend on www/tornado4 instead of www/tornado

  PR:		226548
  Approved by:	christer.edwards (maintainer)

Changes:
  head/sysutils/py-salt/Makefile
Comment 9 Grzegorz Blach freebsd_committer 2018-03-18 10:45:58 UTC
Committed, thanks.
Comment 10 commit-hook freebsd_committer 2018-03-20 10:57:27 UTC
A commit references this bug:

Author: koobs
Date: Tue Mar 20 10:56:52 UTC 2018
New revision: 465081
URL: https://svnweb.freebsd.org/changeset/ports/465081

Log:
  sysutils/py-salt: Bump PORTREVISION

  Chase ports r464891 that switched salt's dependencies from tornado (5.x) to
  tornado (4.x, www/tornado4), as the failure occurs at runtime.

  Since package builds werent affected (packages were created) after the
  ports r464162 regression (updating tornado to 5.x), we need to force a rebuild.

  PR:		226548
  Reported by:	dani-hp (via IRC)

Changes:
  head/sysutils/py-salt/Makefile
Comment 11 Kubilay Kocak freebsd_committer freebsd_triage 2018-03-20 11:02:09 UTC
Assign to committer that resolved.

Note: Users that aren't committers (eg: maintainers) are not made Assignees of issues/bugs. Exceptions are non-committers that are triagers (with special permissions), that close bugs when they are resolved without a commit (such as feedback timeout, unable to reproduce, etc)

tldr: The assignee of a bug is/should always be the user that 'resolves' it.
Comment 12 Kubilay Kocak freebsd_committer freebsd_triage 2018-03-20 11:03:14 UTC
Comment on attachment 191469 [details]
Use www/tornado4 in dependency

Approved by: maintainer (see comment 6)

Please use this attachment flag when approving patches (over comments)
Comment 13 Matthew Leach 2018-03-23 07:52:45 UTC
Thanks All.