Bug 226604 - databases/postgresql[9.6|10]-client: error: This platform is not thread-safe.
Summary: databases/postgresql[9.6|10]-client: error: This platform is not thread-safe.
Status: Closed DUPLICATE of bug 226042
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: pgsql
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-03-14 15:02 UTC by O. Hartmann
Modified: 2018-03-14 16:06 UTC (History)
2 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description O. Hartmann 2018-03-14 15:02:24 UTC
When trying to compile/update any databases/postgresql-client, no matter whether it is 9.6 or 10.3, build process dies, see below.

The problem happens to occur only on one CURRENT machine (12.0-CURRENT #44 r330926: Wed Mar 14 11:42:51 CET 2018 amd64), but I have no clue what this could cause.

[...]
checking for fop... /usr/local/bin/fop
checking thread safety of required library functions... no
configure: error: thread test program failed
This platform is not thread-safe.  Check the file 'config.log' or compile
and run src/test/thread/thread_test for the exact reason.
Use --disable-thread-safety to disable thread safety.
===>  Script "configure" failed unexpectedly.
[...]

and checking config.log it seems this entry points to a problem:

configure:16681: cc -o conftest -Wall -Wmissing-prototypes -Wpointer-arith -Wdeclaration-after-statement -Wendif-labels -Wmissing-format-attribute -Wformat-security -fno-strict-aliasing -fwrapv -Wno-unused-command-line-argument -O2 -pipe -march=native  -fstack-protector -fno-strict-aliasing -D_THREAD_SAFE  -D_REENTRANT -D_THREAD_SAFE -D_POSIX_PTHREAD_SEMANTICS -DIN_CONFIGURE -I/usr/local/include -I/usr/local/include -I/usr/local/include  -L/usr/local/lib -lpthread -L/usr/local/lib  -fstack-protector  -L/usr/local/lib conftest.c -lintl -lssl -lcrypto -lz -lreadline -lcrypt -lm  -lpthread >&5
configure:16681: $? = 0
configure:16681: ./conftest
errno not thread-safe **
exiting
configure:16681: $? = 1
configure: program exited with status 1
configure: failed program was:
| /* confdefs.h */
| #define PACKAGE_NAME "PostgreSQL"
[...]
| #define HAVE_LIBCRYPTO 1
[...]
| #include "./src/test/thread/thread_test.c"
configure:16685: result: no
configure:16690: error: thread test program failed
This platform is not thread-safe.  Check the file 'config.log' or compile
and run src/test/thread/thread_test for the exact reason.
Use --disable-thread-safety to disable thread safety.
[...]
Comment 1 Palle Girgensohn freebsd_committer 2018-03-14 16:06:27 UTC

*** This bug has been marked as a duplicate of bug 226042 ***