Bug 226615 - www/apache24: looks in 20170718-zts for non-thread-safe php modules
Summary: www/apache24: looks in 20170718-zts for non-thread-safe php modules
Status: Closed DUPLICATE of bug 201193
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: freebsd-apache (Nobody)
URL:
Keywords: needs-qa
Depends on:
Blocks:
 
Reported: 2018-03-14 19:19 UTC by MMacD
Modified: 2018-04-08 08:25 UTC (History)
3 users (show)

See Also:
bugzilla: maintainer-feedback? (apache)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description MMacD 2018-03-14 19:19:59 UTC
Not being able to get mysqli to load using packages, I finally said buggrit and built apache24 and php72 from ports with zero special sauce.  Httpd.conf shows that the prefork module is being loaded, not either of the threaded ones, yet apache looks for the nominally-optional php modules in /usr/local/lib/php/20170718-zts anyway.  

If there's some switch I missed seeing, I hope someone will tell me where to find it because I deliberately did NOT set the "force zend thread-safe" switch when building php72, so it should be looking in the vanilla .../20170718 subtree not in the ...-zts one.
Comment 1 Bernard Spil freebsd_committer 2018-03-18 19:27:26 UTC
Aren't you looking at the www/mod_php72 port in this case? The Apache ports don't build the module

from www/mod_php72 pkg-plist:

> libexec/apache24/libphp7.so

That's also where the ZTS option is located.
Comment 2 Bernard Spil freebsd_committer 2018-04-08 08:25:08 UTC

*** This bug has been marked as a duplicate of bug 201193 ***