Bug 226630 - New port: dns/dsp: display statistics collected by DSC (DNS Statistics Collector)
Summary: New port: dns/dsp: display statistics collected by DSC (DNS Statistics Collec...
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: Kurt Jaeger
URL: https://www.dns-oarc.net/oarc/data/dsc
Keywords:
Depends on:
Blocks: 226631
  Show dependency treegraph
 
Reported: 2018-03-15 13:13 UTC by Leo Vandewoestijne
Modified: 2018-03-21 20:13 UTC (History)
1 user (show)

See Also:


Attachments
DSP (2.64 KB, text/plain)
2018-03-15 13:13 UTC, Leo Vandewoestijne
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Leo Vandewoestijne 2018-03-15 13:13:26 UTC
Created attachment 191520 [details]
DSP

I'm submitting ports for DNS-OARC's DNS Statistics Collector project.
The DSC software consists of the following 4 parts:
(continued in follow-up with cross-references)
Comment 1 Leo Vandewoestijne 2018-03-15 13:21:45 UTC
dsc (DNS Statistics Collector)
a tool used for collecting and exploring statistics from busy DNS servers.
https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=226631

dsp (DNS Statistics Presenter) 
can be used to display statistics collected by DSC.
(This PR)

p5-DSC
Perl Library is used to extract and graph DSC data, required by dsp.
https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=226629
 
p5-App-DSC-DataTool / dsc-datatool
Tool for converting, exporting, merging and transforming DSC data.
https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=226628

All was tested with portlint and with poudrier on all current releases both on amd64 as i386.
Comment 2 Mark Linimon freebsd_committer freebsd_triage 2018-03-16 04:35:19 UTC
Give this a more useful Summary.

Note to submitter: it is not necessary to set the Maintainer-Approval flag except for changes to existing ports.
Comment 3 Kurt Jaeger freebsd_committer 2018-03-21 17:45:17 UTC
Testbuild failed:

[00:00:49] [01] [00:00:07] Finished dns/dsp | dsp-2.0.0: Failed: configure
[00:00:49] Stopping 8 builders
[00:00:51] Failed ports: dns/dsp:configure

And:

checking for perl module Getopt::Long... ok
configure: error: Need some Perl modules
===>  Script "configure" failed unexpectedly.


I'm investigating the problem.
Comment 4 Kurt Jaeger freebsd_committer 2018-03-21 17:49:09 UTC
failed because dsp configure does not find DSC::grapher module ?

See

http://people.freebsd.org/~pi/logs/dsp-2.0.0.log
Comment 5 Kurt Jaeger freebsd_committer 2018-03-21 20:02:21 UTC
missing dependency on lang/p5-Switch was the cause of the error.
Comment 6 Kurt Jaeger freebsd_committer 2018-03-21 20:12:53 UTC
Committed, thanks!
Comment 7 commit-hook freebsd_committer 2018-03-21 20:13:28 UTC
A commit references this bug:

Author: pi
Date: Wed Mar 21 20:12:44 UTC 2018
New revision: 465236
URL: https://svnweb.freebsd.org/changeset/ports/465236

Log:
  New port: dns/dsp

  DNS Statistics Presenter (DSP) is a tool used
  for exploring statistics from busy DNS servers
  collected by DNS Statistics Collector (DSC).

  WWW: https://www.dns-oarc.net/dsc/

  PR:		226630
  Submitted by:	Leo Vandewoestijne <freebsd@dns.company>

Changes:
  head/dns/Makefile
  head/dns/dsp/
  head/dns/dsp/Makefile
  head/dns/dsp/distinfo
  head/dns/dsp/pkg-descr
  head/dns/dsp/pkg-plist