Bug 226664 - x11/dmenu: Update to 4.8
Summary: x11/dmenu: Update to 4.8
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Yuri Victorovich
URL:
Keywords:
: 226928 (view as bug list)
Depends on:
Blocks:
 
Reported: 2018-03-16 20:18 UTC by Mateusz Piotrowski
Modified: 2018-04-08 19:31 UTC (History)
2 users (show)

See Also:
bugzilla: maintainer-feedback? (schot)


Attachments
Patch upating x11/dmenu to 4.8 (2.80 KB, patch)
2018-03-16 20:18 UTC, Mateusz Piotrowski
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Mateusz Piotrowski freebsd_committer 2018-03-16 20:18:59 UTC
Created attachment 191561 [details]
Patch upating x11/dmenu to 4.8

4.8 changelog: 
 - https://git.suckless.org/dmenu/log/?qt=range&q=4.7..4.8

Changes in the attached patch:
 - Remove PATCH_SITES.
 - Move FREETYPEINC to MAKE_ARGS from patches. This way the patch for config.mk is smaller.
 - Improve pkg-descr.

Also, there were some maintainer timeouts before. Because of this I am eager to take over the maintainership of this port if the current maintainer wish to step down. :)
Comment 1 Mateusz Piotrowski freebsd_committer 2018-03-16 20:46:35 UTC
(In reply to Mateusz Piotrowski from comment #0)

QA:
 - portlint
 - poudriere: 10.4-RELEASE (amd64), 11.1-RELEASE (i386)
 - my machine: FreeBSD 12.0-CURRENT r330529 (amd64)
Comment 2 Yuri Victorovich freebsd_committer 2018-04-08 07:59:28 UTC
Committed.
Thank you for the update and for taking maintainership!
Comment 3 commit-hook freebsd_committer 2018-04-08 07:59:36 UTC
A commit references this bug:

Author: yuri
Date: Sun Apr  8 07:59:20 UTC 2018
New revision: 466776
URL: https://svnweb.freebsd.org/changeset/ports/466776

Log:
  x11/dmenu: Update 4.7 -> 4.8

  0mp@FreeBSD.org takes maintainership.

  Port changes:
  * Remove extra patches
  * Remove FREETYPEINC patch, add it as a variable to MAKE_ARGS
  * Monor change in pkg-descr
  * Change WWW to https

  PR:		226664
  Submitted by:	Mateusz Piotrowski <0mp@FreeBSD.org>
  Approved by:	schot@a-eskwadraat.nl (maintainer; timeout 22 days)

Changes:
  head/x11/dmenu/Makefile
  head/x11/dmenu/distinfo
  head/x11/dmenu/files/patch-config.mk
  head/x11/dmenu/pkg-descr
Comment 4 Mateusz Piotrowski freebsd_committer 2018-04-08 19:31:00 UTC
*** Bug 226928 has been marked as a duplicate of this bug. ***