Bug 226668 - www/matomo: Fails to build if WWWOWN is not set to www
Summary: www/matomo: Fails to build if WWWOWN is not set to www
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: Torsten Zuehlsdorff
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-03-17 03:55 UTC by Christoph Kliemann
Modified: 2018-05-02 10:51 UTC (History)
0 users

See Also:
tz: maintainer-feedback+


Attachments
Patch for pkg-plist (17.85 KB, patch)
2018-03-17 03:55 UTC, Christoph Kliemann
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Christoph Kliemann 2018-03-17 03:55:50 UTC
Created attachment 191568 [details]
Patch for pkg-plist

Overview:
Build fails if WWWOWN is set to everything but www. 
Looks like a simple search and replace error in pkg-plist.
Multiple files in pkg-plist are listed like this: %%WWWOWN%%.118700.se.png
All affected filenames contain the string "www".
See attached patch for details.

Steps to Reproduce:
1) set WWWOWN=nobody
2) try to build port

Actual Results:
===>  Building package for piwik-3.2.1
[...]
pkg-static: Unable to access file /wrkdirs/usr/ports/www/piwik/work/stage/usr/local/www/piwik/plugins/Morpheus/icons/dist/searchEngines/nobody2.inbox.com.png:No such file or directory
pkg-static: Unable to access file /wrkdirs/usr/ports/www/piwik/work/stage/usr/local/www/piwik/plugins/Morpheus/icons/dist/searchEngines/nobody3.zoek.nl.png:No such file or directory
*** Error code 1

Stop.
make: stopped in /usr/ports/www/piwik

Expected Results: port builds and uses WWWOWN to set correct file permissions.

This is my first report. Please let me know if you need anything else.
Comment 1 commit-hook freebsd_committer 2018-04-25 09:34:24 UTC
A commit references this bug:

Author: tz
Date: Wed Apr 25 09:34:05 UTC 2018
New revision: 468267
URL: https://svnweb.freebsd.org/changeset/ports/468267

Log:
  www/matomo: Fix wrong entries in pkg-plist

  Some "www" strings where replaced with %%%WWWDIR%%% causing build failures,
  if %%%WWWDIR%%% is something other than "www".

  PR:           226668
  Submitted by: freebsd-bugs@cklie.de
  MFH:          2018Q2

Changes:
  head/www/matomo/Makefile
  head/www/matomo/pkg-plist
Comment 2 Torsten Zuehlsdorff freebsd_committer 2018-04-25 09:35:09 UTC
Thank you for the patch. Your PR is fine and very helpful. I just committed it :)

I keep the PR open since i intend to merge the fix into our quarterly branch.
Comment 3 Christoph Kliemann 2018-04-25 19:42:21 UTC
Thank you and all committers for the awesome work you do here! :)
Comment 4 Torsten Zuehlsdorff freebsd_committer 2018-05-02 10:51:16 UTC
The MFH was delayed until more complaints will arrive.

This is due the special circumstance that in quarterly the port is still named www/piwik. So the MFH would require the renaming, update and the bug-fix. Since there is only one complain and its about www/matomo we delay the MFH.