Bug 226720 - www/chromium: hangs frequently on web.whatsapp.com
Summary: www/chromium: hangs frequently on web.whatsapp.com
Status: Closed DUPLICATE of bug 212812
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: freebsd-chromium (Nobody)
URL:
Keywords:
Depends on: 226793
Blocks:
  Show dependency treegraph
 
Reported: 2018-03-19 10:37 UTC by Nicola Mingotti
Modified: 2018-08-15 00:02 UTC (History)
3 users (show)

See Also:
cpm: maintainer-feedback+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Nicola Mingotti 2018-03-19 10:37:56 UTC
I am running FreeBSD-11.1, and latest Chromium package 
chromium-64.0.3282.186_1

I am running with chromium with:
/usr/local/bin/chrome --disable-gpu

Respect to the previous package release this chromium hangs
very often. But, there is a page in which the hangs ratio
has remained very high, that is web.whatsapp.com.

It hangs often in both these cases:

1] When I open the page.

2] When the page was already open and running, then I move 
to other tabs or chromium windows, when I come back to whatsapp
tab it is stuck. I must kill it and try to reload. 

Bye
Nicola
Comment 1 Nicola Mingotti 2018-03-19 10:42:35 UTC
Sorry, I made a mistake and I don't find the way to correct
the original message.

I wanted to say that this version of Chromium hangs RARELY
IN GENERAL compared to the previous package version.

But, it still hangs FREQUENTLY on whatsapp page.

bye
Nicola
Comment 2 Grzegorz Junka 2018-03-19 20:36:19 UTC
Another duplicate of https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=212812 ?
Comment 3 Nicola Mingotti 2018-03-20 07:35:40 UTC
No, it is not the same IMHO.

If it is true that Chromium hangs 10% of times with regular pages
then it hangs at least 60% of times in web.whatsapp.com.

It hangs quite frequently also if you open a GoolgeSheet,
but still, not comparable with web.whatsapp.com wich is absolutely
whe worst case I found, and the page is almost un-usable.


Bye
Nicola
Comment 4 Nicola Mingotti 2018-03-20 07:55:52 UTC
Anyway, I just applied "Tomo Method" from the other thread 
(https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=212812)

1] disable v8 caching 
2] shutdown chromium
3] remove ~/.cache/chromium
4] restart chromium 

... By the end of day I can say something.
Comment 5 Nicola Mingotti 2018-03-20 17:26:05 UTC
After applying "Tomo Method" and a full day of use 
I can state that:

1] The hanging frequency was drastically reduced in general,
i would say the problem almost disappeared. 

2] In web.whatsapp.com website the hang frequency reduced
sensibly but still remains, it hanged a couple of times once
the application was already started.
To have the application working I had to load/kill the page 4-5 times.
Comment 6 Nicola Mingotti 2018-03-21 08:55:59 UTC
With "Tomo Method" on.

Today Whatapp hanged and it was impossible to restart it ! 
Kill the tab, kill the windows, kill chromioum and restart => No effect.

The only way to restart whatsapp web was 
1] kill chromium
2] rm -rf ~/.cache/chromium
2] restart chromium
Comment 7 Carlos J. Puga Medina freebsd_committer 2018-08-15 00:02:58 UTC

*** This bug has been marked as a duplicate of bug 212812 ***