Bug 226898 - devel/aarch64-none-elf-gcc: installation failure on CURRENT: kg-static: Unable to ... :No such file or directory
Summary: devel/aarch64-none-elf-gcc: installation failure on CURRENT: kg-static: Unabl...
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Many People
Assignee: John Baldwin
URL:
Keywords:
: 226905 226923 (view as bug list)
Depends on:
Blocks:
 
Reported: 2018-03-24 19:30 UTC by O. Hartmann
Modified: 2018-04-02 14:14 UTC (History)
4 users (show)

See Also:
bugzilla: maintainer-feedback? (kan)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description O. Hartmann 2018-03-24 19:30:30 UTC
On CURRENT, install process fails at the very last step:

===>  Installing for aarch64-none-elf-gcc-6.3.0_2
===>   Registering installation for aarch64-none-elf-gcc-6.3.0_2 as automatic
pkg-static: Unable to access file /usr/ports/devel/aarch64-none-elf-gcc/work/stage/usr/local/lib/gcc/aarch64-none-elf/6.3.0/include-fixed/README:No such file or directory
pkg-static: Unable to access file /usr/ports/devel/aarch64-none-elf-gcc/work/stage/usr/local/lib/gcc/aarch64-none-elf/6.3.0/include-fixed/limits.h:No such file or directory
pkg-static: Unable to access file /usr/ports/devel/aarch64-none-elf-gcc/work/stage/usr/local/lib/gcc/aarch64-none-elf/6.3.0/include-fixed/syslimits.h:No such file or directory
*** Error code 74

Stop.
make: stopped in /usr/ports/devel/aarch64-none-elf-gcc
Comment 1 Helge Oldach 2018-03-25 04:47:38 UTC
This was fixed for devel/aarch64-gcc with ports r465416. Need to apply here as well.
Comment 2 Helge Oldach 2018-03-25 05:09:19 UTC
And also devel/arm-none-eabi-gcc needs to be fixed in the same way...
Comment 3 Alexander Kabaev freebsd_committer 2018-03-25 14:44:22 UTC
Fallout from work done by John and he is aware of it. The fix is to edit plist accordingly.
Comment 4 Alexander Kabaev freebsd_committer 2018-03-25 20:01:58 UTC
*** Bug 226905 has been marked as a duplicate of this bug. ***
Comment 5 Alexander Kabaev freebsd_committer 2018-03-25 20:02:26 UTC
*** Bug 226923 has been marked as a duplicate of this bug. ***
Comment 6 commit-hook freebsd_committer 2018-03-25 22:07:48 UTC
A commit references this bug:

Author: kan
Date: Sun Mar 25 22:06:45 UTC 2018
New revision: 465549
URL: https://svnweb.freebsd.org/changeset/ports/465549

Log:
  Catchup with r465416 in some extra dependent ports

  PR:		226898

Changes:
  head/devel/aarch64-none-elf-gcc/pkg-plist
  head/devel/arm-none-eabi-gcc/pkg-plist