Bug 226919 - www/firefox: some addons never update and cannot be found via built-in search field
Summary: www/firefox: some addons never update and cannot be found via built-in search...
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: freebsd-gecko mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-03-25 16:31 UTC by Graham Perrin
Modified: 2018-05-23 21:20 UTC (History)
1 user (show)

See Also:
jbeich: maintainer-feedback+


Attachments
A small flood of overdue updates (212.69 KB, image/png)
2018-03-25 16:31 UTC, Graham Perrin
no flags Details
Example A: Session Boss (154.11 KB, image/png)
2018-05-01 05:56 UTC, Graham Perrin
no flags Details
Example A: Session Boss (160.29 KB, image/png)
2018-05-01 06:02 UTC, Graham Perrin
no flags Details
Example A: Session Boss (154.11 KB, image/png)
2018-05-01 06:06 UTC, Graham Perrin
no flags Details
Example A: Session Boss (94.15 KB, image/png)
2018-05-01 06:10 UTC, Graham Perrin
no flags Details
Example A: Session Boss (149.40 KB, image/png)
2018-05-01 06:12 UTC, Graham Perrin
no flags Details
Example A: Session Boss (96.48 KB, image/png)
2018-05-01 06:16 UTC, Graham Perrin
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Graham Perrin 2018-03-25 16:31:43 UTC
Created attachment 191806 [details]
A small flood of overdue updates

AFAICT there's an issue (maybe a regression) with AMO that causes Waterfox on FreeBSD to not receive updates from AMO, if an update is in _some_ way version-specific. 

https://github.com/Fantastitech/Reddactit/issues/3#issuecomment-375965737 for example; 
at https://addons.mozilla.org/addon/reddactit/versions/ it: 

> Works with Firefox for Android 48.0 and later, Firefox 48.0 and later 


=====================
extensions.update.url
=====================

In my case, a change from the preset: 

https://versioncheck.addons.mozilla.org/update/VersionCheck.php?reqVersion=%REQ_VERSION%&id=%ITEM_ID%&version=%ITEM_VERSION%&maxAppVersion=%ITEM_MAXAPPVERSION%&status=%ITEM_STATUS%&appID=%APP_ID%&appVersion=%APP_VERSION%&appOS=%APP_OS%&appABI=%APP_ABI%&locale=%APP_LOCALE%&currentAppVersion=%CURRENT_APP_VERSION%&updateType=%UPDATE_TYPE%&compatMode=%COMPATIBILITY_MODE%

– to Linux-specific: 

https://versioncheck.addons.mozilla.org/update/VersionCheck.php?reqVersion=%REQ_VERSION%&id=%ITEM_ID%&version=%ITEM_VERSION%&maxAppVersion=%ITEM_MAXAPPVERSION%&status=%ITEM_STATUS%&appID=%APP_ID%&appVersion=%APP_VERSION%&appOS=Linux&appABI=%APP_ABI%&locale=%APP_LOCALE%&currentAppVersion=%CURRENT_APP_VERSION%&updateType=%UPDATE_TYPE%&compatMode=%COMPATIBILITY_MODE%

– allowed about:addons to find around twenty updates that were previously not found. 

Tested with 56.0.4.72_1. 

I assume that the workaround will be equally effective with 56.1.0, which I see has been (experimentally) ported :-)

Edge cases
----------

Where an extension that's served by AMO is _truly_ platform specific, it will be inappropriate to install a version for Linux, but in my experience those cases are rare enough to warrant implementing this workaround.


================================
extensions.update.background.url
================================

Maybe hard-code that to Linux as well? My gut feeling is, don't.
Comment 1 Graham Perrin 2018-03-25 17:52:33 UTC
D'oh, 

> …in _some_ way version-specific. …

– I meant, 

> …in _some_ way platform-specific. …
Comment 2 Jan Beich freebsd_committer 2018-03-29 10:23:14 UTC
Probably related to about:addons search field issue e.g.,
- https://addons.mozilla.org/en-US/firefox/search/?q=reddactit&platform=FreeBSD&appver=56.0.2

Another workaround option is to make %OS% return Linux by changing
https://searchfox.org/mozilla-central/rev/028cd8342899/toolkit/xre/nsAppRunner.cpp#870

Let's see if Mozilla fixes AMO first as the issue isn't really specific to Waterfox.
Comment 3 Jan Beich freebsd_committer 2018-05-01 01:37:03 UTC
FWIW, www/firefox in summary indicates the issue is generic to all forks.
Comment 4 Graham Perrin 2018-05-01 05:44:58 UTC
Makes sense, thanks. 

----

> … cannot be found via built-in search field

– and then, if there appears the 'See all … results' prompt, the URL will include 

&platform=FreeBSD

– which may cause the required add-on to be not found, or not suitably prominent. I'll attach screenshots of an example.
Comment 5 Graham Perrin 2018-05-01 05:56:29 UTC
Created attachment 192947 [details]
Example A: Session Boss

Session Boss sought but not found …
Comment 6 Graham Perrin 2018-05-01 06:02:14 UTC
Created attachment 192948 [details]
Example A: Session Boss

Session Boss sought but not found. Aiming to click 'See all 184 results' …
Comment 7 Graham Perrin 2018-05-01 06:06:55 UTC
Created attachment 192949 [details]
Example A: Session Boss

… first page of 186 results, Session Boss not found (not on any of the eight pages) …

----

Side note: 

186 > 184
Comment 8 Graham Perrin 2018-05-01 06:10:27 UTC
Created attachment 192950 [details]
Example A: Session Boss

… Session Boss not amongst find-as-you-type (FAYT) search result.
Comment 9 Graham Perrin 2018-05-01 06:12:31 UTC
Created attachment 192951 [details]
Example A: Session Boss

After cutting &platform=FreeBSD from within the URL, Session Boss is first and foremost.
Comment 10 Graham Perrin 2018-05-01 06:16:14 UTC
Created attachment 192952 [details]
Example A: Session Boss

Session Boss first and foremost amongst FAYT results. 

In other words, &platform=FreeBSD causes FAYT to be non-trustworthy.
Comment 11 commit-hook freebsd_committer 2018-05-23 01:22:12 UTC
A commit references this bug:

Author: jbeich
Date: Wed May 23 01:21:23 UTC 2018
New revision: 470668
URL: https://svnweb.freebsd.org/changeset/ports/470668

Log:
  gecko: mask as Linux on AMO for compatibility

  Many extensions on addons.mozilla.org aren't listed or updated due to
  platform whitelist abuse. On DragonFly the search is broken because
  such a platform isn't recognized.

  PR:		226919
  Reported by:	Graham Perrin

Changes:
  head/mail/thunderbird/Makefile
  head/mail/thunderbird/files/patch-addon-search
  head/www/firefox/Makefile
  head/www/firefox/files/patch-addon-search
  head/www/firefox-esr/Makefile
  head/www/firefox-esr/files/patch-addon-search
  head/www/seamonkey/Makefile
  head/www/seamonkey/files/patch-addon-search
  head/www/waterfox/Makefile
  head/www/waterfox/files/patch-addon-search
Comment 12 commit-hook freebsd_committer 2018-05-23 04:05:24 UTC
A commit references this bug:

Author: jbeich
Date: Wed May 23 04:04:55 UTC 2018
New revision: 470672
URL: https://svnweb.freebsd.org/changeset/ports/470672

Log:
  gecko: adjust targetPlatform after r470668

  PR:		226919
  Reported by:	Corpo (for Lightning)

Changes:
  head/mail/thunderbird/Makefile
  head/mail/thunderbird/files/patch-addon-search
  head/www/firefox/Makefile
  head/www/firefox/files/patch-addon-search
  head/www/firefox-esr/Makefile
  head/www/firefox-esr/files/patch-addon-search
  head/www/seamonkey/Makefile
  head/www/seamonkey/files/patch-addon-search
  head/www/waterfox/Makefile
  head/www/waterfox/files/patch-addon-search
Comment 13 commit-hook freebsd_committer 2018-05-23 04:21:38 UTC
A commit references this bug:

Author: jbeich
Date: Wed May 23 04:20:40 UTC 2018
New revision: 470673
URL: https://svnweb.freebsd.org/changeset/ports/470673

Log:
  mail/thunderbird: drop LIGHTNING as it's unusable after r470672

  PR:		226919

Changes:
  head/UPDATING
  head/mail/thunderbird/Makefile
  head/www/firefox/Makefile.options
  head/www/seamonkey/Makefile
Comment 14 commit-hook freebsd_committer 2018-05-23 04:50:02 UTC
A commit references this bug:

Author: jbeich
Date: Wed May 23 04:49:03 UTC 2018
New revision: 470674
URL: https://svnweb.freebsd.org/changeset/ports/470674

Log:
  mail/thunderbird: back out r470673 as AMO version lacks libical

  PR:		226919
  Pointy hat to:	jbeich (too sleepy to wait for QA)

Changes:
  head/UPDATING
  head/mail/thunderbird/Makefile
  head/www/firefox/Makefile.options
  head/www/seamonkey/Makefile
Comment 15 commit-hook freebsd_committer 2018-05-23 05:19:27 UTC
A commit references this bug:

Author: jbeich
Date: Wed May 23 05:19:19 UTC 2018
New revision: 470675
URL: https://svnweb.freebsd.org/changeset/ports/470675

Log:
  gecko: restore support for native extensions after r470668/r470672

  PR:		226919

Changes:
  head/mail/thunderbird/Makefile
  head/mail/thunderbird/files/patch-addon-search
  head/www/firefox/Makefile
  head/www/firefox/files/patch-addon-search
  head/www/firefox-esr/Makefile
  head/www/firefox-esr/files/patch-addon-search
  head/www/seamonkey/Makefile
  head/www/seamonkey/files/patch-addon-search
  head/www/waterfox/Makefile
  head/www/waterfox/files/patch-addon-search
Comment 16 commit-hook freebsd_committer 2018-05-23 19:56:51 UTC
A commit references this bug:

Author: jbeich
Date: Wed May 23 19:56:16 UTC 2018
New revision: 470716
URL: https://svnweb.freebsd.org/changeset/ports/470716

Log:
  MFH: r470668 r470672 r470675

  gecko: mask as Linux on AMO for compatibility

  Many extensions on addons.mozilla.org aren't listed or updated due to
  platform whitelist abuse. On DragonFly the search is broken because
  such a platform isn't recognized.

  PR:		226919
  Reported by:	Graham Perrin, Corpo (Lightning)
  Approved by:	ports-secteam blanket

Changes:
_U  branches/2018Q2/
  branches/2018Q2/mail/thunderbird/Makefile
  branches/2018Q2/mail/thunderbird/files/patch-addon-search
  branches/2018Q2/www/firefox/Makefile
  branches/2018Q2/www/firefox/files/patch-addon-search
  branches/2018Q2/www/firefox-esr/Makefile
  branches/2018Q2/www/firefox-esr/files/patch-addon-search
  branches/2018Q2/www/seamonkey/Makefile
  branches/2018Q2/www/seamonkey/files/patch-addon-search
  branches/2018Q2/www/waterfox/Makefile
  branches/2018Q2/www/waterfox/files/patch-addon-search
Comment 17 Graham Perrin 2018-05-23 20:09:41 UTC
Waterfox 56.2.0.13_1
====================

Test results with an almost perfectly clean profile on FreeBSD-CURRENT.

Beginnings at about:addons
--------------------------

Seeking 'Session Boss' finds Session Boss 1.4 uppermost, and the link at the foot of the page refers to <https://addons.mozilla.org/en-US/firefox/search/?q=session%20boss&platform=Linux&appver=56.2.0> with Session Boss first amongst 200 results. 

☑ 1.4 is truly the most recent version. 

Seeking 'Disconnect' finds Disconnect 5.18.21 uppermost, and the link at the foot of the page refers to  <https://addons.mozilla.org/en-US/firefox/search/?q=disconnect&platform=Linux&appver=56.2.0> with Disconnect first amongst 31 results. 

☑ 5.18.21 is truly the most recent version

– compare with the outdated, incompatible 3.15.3 that was inadvertently installed at <https://github.com/MrAlex94/Waterfox/issues/578#issue-325408838> with Waterfox 56.2.0.13. OOTB 56.2.0.13_1 is significantly better. 

----

$ pkg info waterfox | grep Version
Version        : 56.2.0.13_1
$ date ; uname -v
Wed 23 May 2018 20:47:20 BST
FreeBSD 12.0-CURRENT #2 r333587: Mon May 14 01:59:02 BST 2018     root@momh167-gjp4-hpelitebook8570p-freebsd:/usr/obj/usr/src/amd64.amd64/sys/GENERIC 

----

Big thanks to Jan.
Comment 18 commit-hook freebsd_committer 2018-05-23 20:11:05 UTC
A commit references this bug:

Author: jbeich
Date: Wed May 23 20:10:33 UTC 2018
New revision: 470718
URL: https://svnweb.freebsd.org/changeset/ports/470718

Log:
  MFH: r470668 r470672 r470675

  gecko: mask as Linux on AMO for compatibility (r470716 followup)

  Many extensions on addons.mozilla.org aren't listed or updated due to
  platform whitelist abuse. On DragonFly the search is broken because
  such a platform isn't recognized.

  PR:		226919
  Reported by:	Graham Perrin, Corpo (Lightning)
  Approved by:	ports-secteam blanket

Changes:
  branches/2018Q2/mail/thunderbird/files/patch-addon-search
  branches/2018Q2/mail/thunderbird/files/patch-addon-search
  branches/2018Q2/www/firefox/files/patch-addon-search
  branches/2018Q2/www/firefox/files/patch-addon-search
  branches/2018Q2/www/firefox-esr/files/patch-addon-search
  branches/2018Q2/www/firefox-esr/files/patch-addon-search
  branches/2018Q2/www/seamonkey/files/patch-addon-search
  branches/2018Q2/www/seamonkey/files/patch-addon-search
  branches/2018Q2/www/waterfox/files/patch-addon-search
  branches/2018Q2/www/waterfox/files/patch-addon-search
Comment 19 Jan Beich freebsd_committer 2018-05-23 21:20:30 UTC
Thanks for testing.