Bug 226923 - devel/arm-none-eabi-gcc: build fails
Summary: devel/arm-none-eabi-gcc: build fails
Status: Closed DUPLICATE of bug 226898
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Alexander Kabaev
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-03-25 19:42 UTC by Martin Birgmeier
Modified: 2018-03-26 06:11 UTC (History)
1 user (show)

See Also:
bugzilla: maintainer-feedback? (kan)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Birgmeier 2018-03-25 19:42:51 UTC
Building devel/arm-none-eabi-gcc using portmaster fails:

...
===>  Installing for arm-none-eabi-gcc-6.3.0_2
===>  Checking if arm-none-eabi-gcc already installed
===>   Registering installation for arm-none-eabi-gcc-6.3.0_2 as automatic
pkg-static: Unable to access file /usr/tmp/a/SRC/FreeBSD-ports/head/devel/arm-none-eabi-gcc/work/stage/usr/local/lib/gcc/arm-none-eabi/6.3.0/include-fixed/README:No such file or directory
pkg-static: Unable to access file /usr/tmp/a/SRC/FreeBSD-ports/head/devel/arm-none-eabi-gcc/work/stage/usr/local/lib/gcc/arm-none-eabi/6.3.0/include-fixed/limits.h:No such file or directory
pkg-static: Unable to access file /usr/tmp/a/SRC/FreeBSD-ports/head/devel/arm-none-eabi-gcc/work/stage/usr/local/lib/gcc/arm-none-eabi/6.3.0/include-fixed/syslimits.h:No such file or directory
*** Error code 74

Stop.
make: stopped in /a/SRC/FreeBSD-ports/head/devel/arm-none-eabi-gcc

===>>> Installation of arm-none-eabi-gcc-6.3.0_2 (devel/arm-none-eabi-gcc) failed
===>>> Aborting update

===>>> Update for devel/arm-none-eabi-gcc failed
===>>> Aborting update

===>>> Update for sysutils/u-boot-rpi failed
===>>> Aborting update

===>>> The following actions were performed:
        Installation of devel/arm-none-eabi-binutils (arm-none-eabi-binutils-2.30_2,1)


===>>> You can restart from the point of failure with this command line:
       portmaster <flags> sysutils/u-boot-rpi devel/arm-none-eabi-gcc sysutils/u-boot-tools 

This command has been saved to /tmp/portmasterfail.txt

portmaster -a  1260.35s user 267.91s system 142% cpu 17:56.13 total
[1]#

The missing directory "include-fixed" can be found in the port build dir .../devel/arm-none-eabi-gcc/work/.build/gcc/include-fixed; creating a symlink to it in .../devel/arm-none-eabi-gcc/work/stage/usr/local/lib/gcc/arm-none-eabi/6.3.0 allows the install to complete but is not a real solution.
Comment 1 Martin Birgmeier 2018-03-25 20:01:16 UTC
Same with devel/aarch64-none-elf-gcc
Comment 2 Alexander Kabaev freebsd_committer 2018-03-25 20:02:26 UTC

*** This bug has been marked as a duplicate of bug 226898 ***
Comment 3 Martin Birgmeier 2018-03-26 06:11:55 UTC
Thanks for the quick fix in bug #226898.

-- Martin