Bug 227032 - www/py-django-mptt: assign to Django 1.11 (together with www/py-django-js-asset)
Summary: www/py-django-mptt: assign to Django 1.11 (together with www/py-django-js-asset)
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Martin Wilke
URL:
Keywords: patch
Depends on: 227670 228092
Blocks: 227416 228136
  Show dependency treegraph
 
Reported: 2018-03-28 12:19 UTC by Kai Knoblich
Modified: 2018-05-21 15:57 UTC (History)
4 users (show)

See Also:
bugzilla: maintainer-feedback? (cs)


Attachments
py-django-mptt-dependeny.patch (803 bytes, patch)
2018-03-28 12:19 UTC, Kai Knoblich
no flags Details | Diff
py-django-mptt_RUN_DEPENDS.patch (745 bytes, patch)
2018-03-29 14:41 UTC, Kai Knoblich
no flags Details | Diff
django-mptt.patch (1.36 KB, patch)
2018-05-09 11:04 UTC, Kai Knoblich
kai: maintainer-approval? (cs)
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Kai Knoblich freebsd_committer 2018-03-28 12:19:29 UTC
Created attachment 191903 [details]
py-django-mptt-dependeny.patch

Hello,

the Python package py-django-mptt depends upon the www/py-django-js-asset package, which has been added to the ports tree recently.

The attached patch fixes the dependency issue and prepares the port for higher Django versions.
--
Cheers
Kai
Comment 1 Yuri Victorovich freebsd_committer 2018-03-28 17:07:52 UTC
Committed, thanks!
Comment 2 commit-hook freebsd_committer 2018-03-28 17:08:08 UTC
A commit references this bug:

Author: yuri
Date: Wed Mar 28 17:07:46 UTC 2018
New revision: 465823
URL: https://svnweb.freebsd.org/changeset/ports/465823

Log:
  www/py-django-mptt: Add missing dependency

  PR:		227032
  Submitted by:	Kai <freebsd_ports@k-worx.org>
  Approved by:	portmgr blanket

Changes:
  head/www/py-django-mptt/Makefile
Comment 3 Kai Knoblich freebsd_committer 2018-03-29 14:40:30 UTC
(In reply to commit-hook from comment #2)

Hello Yuri,

the commit has been reverted in r465876 due build failures with the ports www/py-django-cms and py-django-dpaste.

The root cause for the failures is the port www/py-django-js-asset, which depends at the moment on the www/py-django meta port instead of www/py-django18 .

I opened a PR (see https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=227066) with a patch for www/py-django-js-asset which should remedy the root cause.

For py-django-mptt I'll also attach a patch which will fix the RUN_DEPENDS. 

QA:
~~~
- poudriere (11.1-RELEASE amd64 + i386) for each py27 + py36 flavor -> OK
- portlint -> OK

I tested the patch also against the ports, that depends on www/py-django-mptt:

For www/py-django-cms:
- poudriere (11.1-RELEASE amd64 + i386) for the py27 flavor -> OK
- poudriere (11.1-RELEASE amd64 + i386) for each py27 + py36 flavor -> OK

--
Cheers
Kai
Comment 4 Kai Knoblich freebsd_committer 2018-03-29 14:41:09 UTC
Created attachment 191929 [details]
py-django-mptt_RUN_DEPENDS.patch
Comment 5 Yuri Victorovich freebsd_committer 2018-03-29 15:30:22 UTC
Reverted in r465876 due to 2 dependency failures.
Comment 6 Yuri Victorovich freebsd_committer 2018-03-29 16:29:13 UTC
Hi Kai,

So this can be committed?
I verified that all py-django-* ports and their dependent ports build now.

Yuri
Comment 7 Kai Knoblich freebsd_committer 2018-03-29 19:02:15 UTC
(In reply to Yuri Victorovich from comment #6)

Hello Yuri,

thank you for your info. I think, the commit can be done then.
--
Cheers
Kai
Comment 8 Kai Knoblich freebsd_committer 2018-05-09 11:04:02 UTC
Created attachment 193203 [details]
django-mptt.patch

Attached is a new patch that does following:

- assigns www/py-django-mptt to Django 1.11
- assigns www/py-django-js-asset to Django 1.11 (my approval is given)

QA:
~~~
- poudriere (11.1-RELEASE amd64 + i386) for each py27 + py36 flavor -> OK
- portlint -> OK

Note:
Following dependencies must be cleared first before this patch can be committed:
- www/py-django-cms must be updated to 3.5.2 (see also PR #228092: https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=228092)
- www/py-django-dpaste must be updated to 2.13 (see also PR #227670: https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=227670)
Comment 9 Martin Wilke freebsd_committer 2018-05-10 15:17:37 UTC
Hi Yuri,

Would u mind when i take this over, because its related to this https://wiki.freebsd.org/ports/django , thanks in advance.
Comment 10 Yuri Victorovich freebsd_committer 2018-05-10 17:23:05 UTC
(In reply to Martin Wilke from comment #9)

Ok!

Yuri
Comment 11 commit-hook freebsd_committer 2018-05-21 15:21:10 UTC
A commit references this bug:

Author: miwi
Date: Mon May 21 15:20:18 UTC 2018
New revision: 470553
URL: https://svnweb.freebsd.org/changeset/ports/470553

Log:
  - Added missing dependency of www/py-django-js-asset
  - Switch to py-django111
  - Bump PORTREVISION

  PR:	227032
  Submitted by:	freebsd_ports@k-worx.org
  Sponsored by:	iXsystems Inc.

Changes:
  head/www/py-django-js-asset/Makefile
  head/www/py-django-mptt/Makefile