Bug 227051 - print/hplip: hp-setup indicates failure but generates ppd file
Summary: print/hplip: hp-setup indicates failure but generates ppd file
Status: New
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Ben Woods
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-03-28 20:22 UTC by freebsd
Modified: 2018-03-28 20:22 UTC (History)
0 users

See Also:
bugzilla: maintainer-feedback? (woodsb02)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description freebsd 2018-03-28 20:22:38 UTC
hplip installs hp-setup to generate ppd files.
If one installs hplip without the FAX option,
and then attempts to generate a ppd file for an HP Officejet Pro 8500 a909g, the program finishes with an error message indicating failure.  However, it has written the appropriate file to /usr/local/share/ppd.

When I did this, cups still did not work.  I was left wondering if the ppd file generated was in error somehow, or whether some other activity needed to be done.
The cups log shows that it properly reloaded the changed ppd file, but then claimed it could not open the file:
D [28/Mar/2018:11:23:09 -0600] [Client 1] Processing GET /printers/HP_Officejet_Pro_8500_A909g
...
D [28/Mar/2018:11:23:09 -0600] [CGI] envp[26] = "SCRIPT_FILENAME=/usr/local/share/doc/cups/printers/HP_Officejet_Pro_8500_A909g"
...
D [28/Mar/2018:11:23:09 -0600] [Client 3] Returning IPP successful-ok for Get-Printer-Attributes (ipp://localhost/printers/HP_Office
jet_Pro_8500_A909g) from localhost
...
   D [28/Mar/2018:11:23:09 -0600] [CGI] cgiSetArray: job_printer_state_message[0]=\"Failed to open PPD: /usr/local/etc/cups/ppd/HP_Officejet_Pro_8500_A909g.ppd\"

I moved the generated ppd file aside and tried to regenerate the ppd file, but hp-setup wouldn't do it without creating another printer queue.  I finally deleted the cups queue (via the cups web interface), rebuilt the hplip package with the FAX and SCAN options enabled, and re-ran hp-setup to regenerate the queue.  At this point it worked.

However, the ppd file generated was the same as the previous one.  So it appears something else didn't get done when hp-setup indicated it had an error generating the ppd file because of no fax capabilities.

As a side-note, hp-setup did not give me the option of using a different protocol.  The generated queue was:
  hp:/net/Officejet_Pro_8500_A909g?ip=aaa.bbb.ccc.ddd
I had to use the cups web interface to change it to what I wanted, which was
  socket://aaa.bbb.ccc.ddd:9100