Bug 227079 - x11/xkbcomp: Update to 1.4.1, add LICENSE_FILE
Summary: x11/xkbcomp: Update to 1.4.1, add LICENSE_FILE
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Yuri Victorovich
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-03-29 17:12 UTC by Dmitri Goutnik
Modified: 2018-05-02 21:23 UTC (History)
2 users (show)

See Also:
bugzilla: maintainer-feedback? (x11)


Attachments
patch file (1.09 KB, patch)
2018-03-29 17:12 UTC, Dmitri Goutnik
dmgk: maintainer-approval?
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Dmitri Goutnik freebsd_committer 2018-03-29 17:12:35 UTC
Created attachment 191943 [details]
patch file

* Update to 1.4.1
* Add LICENSE_FILE
* While here, pet portlint (USE order)

QA:
  poudriere testport: OK (11a, 10i)
Comment 1 commit-hook freebsd_committer 2018-04-29 21:57:09 UTC
A commit references this bug:

Author: yuri
Date: Sun Apr 29 21:57:06 UTC 2018
New revision: 468662
URL: https://svnweb.freebsd.org/changeset/ports/468662

Log:
  x11/xkbcomp: Update 1.4.0 -> 1.4.1

  Port changes:
  * Add LICENSE_FILE
  * Order USExx section

  PR:		227079
  Submitted by:	Dmitri Goutnik <dg@syrec.org>
  Approved by:	maintainer's timeout (x11@FreeBSD.org; 31 days)

Changes:
  head/x11/xkbcomp/Makefile
  head/x11/xkbcomp/distinfo
Comment 2 Yuri Victorovich freebsd_committer 2018-04-29 21:57:20 UTC
Committed, thanks!
Comment 3 jakub_lach 2018-05-01 15:02:26 UTC
After update, 

xorg.conf:

Section "InputDevice"
        Identifier  "Keyboard0"
        Driver      "kbd"
        Option "XkbRules" "xorg"
        Option "XkbModel" "pc105"
        Option "XkbLayout" "pl"
        Option    "XkbOptions"  "lv3:ralt_switch_multikey"
EndSection

result:

syntax error: line 500 of pl
The XKEYBOARD keymap compiler (xkbcomp) reports:
> Error:            Error interpreting include file "pl"
>                   Exiting
>                   Abandoning symbols file "default"
Errors from xkbcomp are not fatal to the X server

I have lost l18n.
Comment 4 Yuri Victorovich freebsd_committer 2018-05-02 04:18:03 UTC
(In reply to jakub_lach from comment #3)

Jakub,

If this is a problem for you, you should complain to the upstream of xkbcomp because this commit was a simple version update.

Regards,
Yuri
Comment 5 jakub_lach 2018-05-02 19:44:29 UTC
(In reply to Yuri Victorovich from comment #4)

I've actually confirmed this is rather a x11/xkeyboard-config update 2.21 -> 2.23.1 problem. Reverting to the old one fixes it. It's pretty major regression or undocumented "feature".
Comment 6 Yuri Victorovich freebsd_committer 2018-05-02 20:26:07 UTC
(In reply to jakub_lach from comment #5)

Please complain to the upstream then. -)
Comment 7 jakub_lach 2018-05-02 21:15:08 UTC
(In reply to Yuri Victorovich from comment #6)

Sure, I might as well, though is that really how ports are supposed to work?
Comment 8 Yuri Victorovich freebsd_committer 2018-05-02 21:22:39 UTC
(In reply to jakub_lach from comment #7)

But what do you expect should happen from the port side?
Comment 9 jakub_lach 2018-05-02 21:23:17 UTC
(In reply to jakub_lach from comment #7)

https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=227935#c2