Bug 227115 - sysutils/htop: Pressing F9 to kill a process results in htop exiting with a "htop: No such file or directory" message
Summary: sysutils/htop: Pressing F9 to kill a process results in htop exiting with a "...
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: amd64 Any
: --- Affects Some People
Assignee: Tobias Kortkamp
URL:
Keywords: patch
: 227819 (view as bug list)
Depends on:
Blocks:
 
Reported: 2018-03-30 15:49 UTC by Philipp Engel
Modified: 2018-05-05 00:32 UTC (History)
5 users (show)

See Also:
koobs: maintainer-feedback? (gaod)


Attachments
htop.diff (859 bytes, patch)
2018-04-20 09:56 UTC, Tobias Kortkamp
tobik: maintainer-approval? (gaod)
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Philipp Engel 2018-03-30 15:49:55 UTC
Trying to kill a process with htop terminates htop and leads to the error message "htop: No such file or directory".
Comment 1 Mateusz Piotrowski freebsd_committer 2018-03-30 20:31:16 UTC
(In reply to Philipp Engel from comment #0)

I experience the same behaviour on FreeBSD 12.0-CURRENT r330529 amd64 running htop 2.1.0.26.
Comment 2 Hung-Yi Chen 2018-04-01 09:10:54 UTC
Upstream already fixed the issue.

I’ll send a PR later.
Comment 3 Kubilay Kocak freebsd_committer freebsd_triage 2018-04-01 09:17:38 UTC
(In reply to Hung-Yi Chen from comment #2)

Please use this issue/PR
Comment 4 Graham Perrin 2018-04-02 19:25:27 UTC
https://github.com/hishamhm/htop/commit/dc050e8088e140d63865f058fa4b926c3571b783

> Fix overflow for signals >= 100.
Comment 5 Tobias Kortkamp freebsd_committer 2018-04-20 09:56:06 UTC
Created attachment 192678 [details]
htop.diff

htop 2.2.0 seems to fix the problem, so can we update?
Comment 6 Mateusz Piotrowski freebsd_committer 2018-04-28 00:15:15 UTC
*** Bug 227819 has been marked as a duplicate of this bug. ***
Comment 7 SF 2018-04-28 07:35:35 UTC
"sysutils/htop: htop: No such file or directory" is misleading, next time you should mension f9 within the headlines.
Comment 8 commit-hook freebsd_committer 2018-05-05 00:30:40 UTC
A commit references this bug:

Author: tobik
Date: Sat May  5 00:29:42 UTC 2018
New revision: 469081
URL: https://svnweb.freebsd.org/changeset/ports/469081

Log:
  sysutils/htop: Update to 2.2.0

  Among other changes this fixes a regression where trying to kill a
  process with htop terminates htop and leads to the error message
  "htop: No such file or directory".

  Changes:	https://github.com/hishamhm/htop/compare/2.1.0-26-g697f5bb...2.2.0
  PR:		227115
  Submitted by:	tobik
  Reported by:	Philipp Engel <kidon@posteo.de>
  Approved by:	Hung-Yi Chen <gaod@hychen.org> (maintainer timeout, 2 weeks)

Changes:
  head/sysutils/htop/Makefile
  head/sysutils/htop/distinfo