Bug 227122 - www/nginx: switching on http_dav_module doesn't change a thing
Summary: www/nginx: switching on http_dav_module doesn't change a thing
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Jochen Neumeister
URL:
Keywords:
: 227752 (view as bug list)
Depends on:
Blocks:
 
Reported: 2018-03-30 19:25 UTC by Maxim Filimonov
Modified: 2018-04-24 20:25 UTC (History)
6 users (show)

See Also:
bugzilla: maintainer-feedback? (joneum)


Attachments
nginx options (11.09 KB, text/plain)
2018-03-30 19:25 UTC, Maxim Filimonov
no flags Details
the patch that fixes it all (573 bytes, patch)
2018-03-30 19:47 UTC, Maxim Filimonov
no flags Details | Diff
the patch that fixes it all (625 bytes, patch)
2018-03-30 22:04 UTC, Maxim Filimonov
no flags Details | Diff
the patch that fixes it all (625 bytes, patch)
2018-03-30 22:04 UTC, Maxim Filimonov
no flags Details | Diff
nginx_options_fix (1000 bytes, patch)
2018-04-19 11:34 UTC, Sergey Akhmatov
sergey: maintainer-approval? (joneum)
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Maxim Filimonov 2018-03-30 19:25:33 UTC
Created attachment 191988 [details]
nginx options

Here are the options I used to compile nginx:
(see nginx-options I attached)
And here's what the newly installed nginx binary thinks about how it was configured:
% /usr/local/sbin/nginx -V
nginx version: nginx/1.12.2
built with OpenSSL 1.0.2k-freebsd  26 Jan 2017
TLS SNI support enabled
configure arguments: --prefix=/usr/local/etc/nginx --with-cc-opt='-I /usr/local/include' --with-ld-opt='-L /usr/local/lib' --conf-path=/usr/local/etc/nginx/nginx.conf --sbin-path=/usr/local/sbin/nginx --pid-path=/var/run/nginx.pid --error-log-path=/var/log/nginx/error.log --user=www --group=www --modules-path=/usr/local/libexec/nginx --with-file-aio --with-threads --without-mail_imap_module --without-mail_pop3_module --without-mail_smtp_module --http-client-body-temp-path=/var/tmp/nginx/client_body_temp --http-fastcgi-temp-path=/var/tmp/nginx/fastcgi_temp --http-proxy-temp-path=/var/tmp/nginx/proxy_temp --http-scgi-temp-path=/var/tmp/nginx/scgi_temp --http-uwsgi-temp-path=/var/tmp/nginx/uwsgi_temp --http-log-path=/var/log/nginx/access.log --with-http_addition_module --with-http_auth_request_module --with-http_flv_module --with-http_gunzip_module --with-http_gzip_static_module --with-http_random_index_module --with-http_realip_module --with-pcre --with-http_secure_link_module --with-http_slice_module --with-http_ssl_module --with-http_stub_status_module --with-http_sub_module --with-http_v2_module --with-stream_ssl_module --add-module=/wrkdirs/usr/ports/www/nginx/work/nginx-dav-ext-module-0.1.0 --with-stream=dynamic --add-dynamic-module=/wrkdirs/usr/ports/www/nginx/work/ngx_devel_kit-0.3.0 --add-dynamic-module=/wrkdirs/usr/ports/www/nginx/work/nginx-auth-ldap-42d195d --add-dynamic-module=/wrkdirs/usr/ports/www/nginx/work/ngx_http_auth_pam_module-1.5.1 --add-dynamic-module=/wrkdirs/usr/ports/www/nginx/work/ngx-fancyindex-0.4.2 --add-dynamic-module=/wrkdirs/usr/ports/www/nginx/work/lua-nginx-module-0.10.11

Let me be even more specific here:
% /usr/local/sbin/nginx -V 2>&1 | grep with-http_dav_module
%

As you can see, no webdav support whatsoever. How did the person who last "fixed" the port manage to break this?
Comment 1 Maxim Filimonov 2018-03-30 19:45:58 UTC
That's how (patch attached)
Comment 2 Maxim Filimonov 2018-03-30 19:47:33 UTC
Created attachment 191990 [details]
the patch that fixes it all

Someone changed HTTP_DAV_CONFIGURE_ON to HTTP_DAV_CONFIGURE_ARGS, this is how it stopped working.

Please be careful while changing stuff. Some people may not catch this as quickly.
Comment 3 Maxim Filimonov 2018-03-30 22:04:04 UTC
Created attachment 191992 [details]
the patch that fixes it all

In fact, this one is even better.
Comment 4 Maxim Filimonov 2018-03-30 22:04:47 UTC
Created attachment 191993 [details]
the patch that fixes it all

Forgot the patch flag.
Comment 5 mgrooms 2018-04-16 18:03:29 UTC
This is a problem for me as well. I emailed a similar patch to the maintainer but haven't heard back. Can someone commit this please?
Comment 6 Sergey Akhmatov 2018-04-19 11:34:57 UTC
Created attachment 192645 [details]
nginx_options_fix

HTTP_DAV is not the only one with option-helpers misuse.
Option HTTP_MP4 is affected by the same issue.

Consider adding to the patch.
Comment 7 Jochen Neumeister freebsd_committer 2018-04-22 15:56:15 UTC
Excuse the delay. We've been working on implementing HTTP_AUTH_KRB5 in NGINX in the last few weeks. This is now complete. Now I have time for this problem. Thanks for the report.
Comment 8 Bernard Spil freebsd_committer 2018-04-24 17:52:11 UTC
(In reply to Maxim Filimonov from comment #0)

Hi Maxim,

Did you check the diff on the commit that broke this feature? Basically it's a whole new port, no stone (line) has been left unturned (unmodified). That's how this feature broke.

I'm sorry we broke this, but the port really needed a big overhaul. We'll get this fixed asap.

Cheers, Bernard.
Comment 9 Bernard Spil freebsd_committer 2018-04-24 17:58:32 UTC
(In reply to Bernard Spil from comment #8)

Sorry Maxim, I was out of line. this has long been fixed and the whole port superseeded with the new version.
Comment 10 mgrooms 2018-04-24 18:23:22 UTC
Why was this marked as fixed? Perhaps I'm missing something, but when I try to compile the latest version of the port ( nginx-1.14.0,2 ), it still doesn't include the two features in question ( dav & mp4 ) without changing HTTP_XXX_ARGS= to HTTP_XXX_ON= in the Makefile.
Comment 11 Bernard Spil freebsd_committer 2018-04-24 20:12:33 UTC
*** Bug 227752 has been marked as a duplicate of this bug. ***
Comment 12 commit-hook freebsd_committer 2018-04-24 20:14:48 UTC
A commit references this bug:

Author: brnrd
Date: Tue Apr 24 20:13:49 UTC 2018
New revision: 468240
URL: https://svnweb.freebsd.org/changeset/ports/468240

Log:
  www/nginx: Fix options

   - OPT_CONFIGURE_ARGS is not a thing

  PR:		227122
  Submitted by:	Maxim Filimonov <che bein link>
  Approved by:	fixit blanket

Changes:
  head/www/nginx/Makefile
Comment 13 mgrooms 2018-04-24 20:25:18 UTC
Thanks!