Bug 227124 - emulators/open-vm-tools - VMware Tools open-vm-tools 10.2.5 has been released.
Summary: emulators/open-vm-tools - VMware Tools open-vm-tools 10.2.5 has been released.
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: Josh Paetzel
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-03-30 21:00 UTC by John Wolfe
Modified: 2018-05-28 02:05 UTC (History)
6 users (show)

See Also:
bugzilla: maintainer-feedback? (jpaetzel)


Attachments
patch for 10.2.5 version (8.90 KB, text/plain)
2018-04-18 02:58 UTC, Josh Paetzel
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Comment 1 Josh Paetzel freebsd_committer 2018-04-18 02:58:00 UTC
Created attachment 192608 [details]
patch for 10.2.5 version
Comment 2 Phillip R. Jaenke 2018-04-30 21:56:10 UTC
This build does not appear to fully address a repeating issue I have been running into. No error is reported by host or guest, but guestd appears to stop communicating, resulting in the classic 'VMware Tools Not Installed' message in vCenter. There isn't any clear trigger, and restarting guestd seems to fix it. 

Reproduces on three guests now, with the hosts running 6.5.0 7388607. What information is needed here to debug further?
Comment 3 John Wolfe 2018-05-01 01:06:46 UTC
(In reply to Phillip R. Jaenke from comment #2)
Hi Phillip,

This PR is tracking the integration of open-vm-tools into the FreeBSD /usr/port tree and it would be helpful to not mix issues in this one PR.

Would you please file a separate problem report against emulators/open-vm-tools and add me to the CC list.   In that new PR please begin by providing the following details.

- FBSD release(s) on which you are running open-vm-tools.
- The statement "This build does not appear to fully address a repeating issue I have been running into." suggests that other versions of OVT have been tried along the way
  - What versions of OVT have you tried before this?
  - "not .. fully address" suggests something has change; please explain the difference.
  - How are you getting OVT onto your system - both earlier versions and 10.2.5?
    - FBSD pkg repositories
    - make install from /usr/ports
    - build from the VMware open-vm-tools source tar bundle.
      - If this, how are you starting the vmtoolsd daemon during start-up?

Thanks
Comment 4 Phillip R. Jaenke 2018-05-01 18:57:59 UTC
Sure thing, John. Opened as https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=227906
Comment 5 Josh Paetzel freebsd_committer 2018-05-28 02:05:07 UTC
Committed, thanks!
Comment 6 commit-hook freebsd_committer 2018-05-28 02:05:22 UTC
A commit references this bug:

Author: jpaetzel
Date: Mon May 28 02:04:39 UTC 2018
New revision: 471014
URL: https://svnweb.freebsd.org/changeset/ports/471014

Log:
  Update to version 10.2.5

  For the most part this is just to track upstream for FreeBSD.
  In particular 10.2.0 introduced a regression whereby UFS support
  was dropped.  The fix was backported to the FreeBSD port of 10.2.0
  in lieu of waiting for 10.2.5 to be released.

  PR:	227124
  Submitted by:	John Wolfe <jwolfe@vmware.com>

Changes:
  head/emulators/open-vm-tools/Makefile
  head/emulators/open-vm-tools/distinfo
  head/emulators/open-vm-tools/files/extra-patch-modules_freebsd_vmxnet_net__compat.h
  head/emulators/open-vm-tools/files/patch-configure.ac
  head/emulators/open-vm-tools/files/patch-lib_guestApp_guestApp.c
  head/emulators/open-vm-tools/files/patch-lib_include_vm__basic__types.h
  head/emulators/open-vm-tools/files/patch-lib_misc_util__misc.c
  head/emulators/open-vm-tools/files/patch-lib_vmCheck_vmcheck.c
  head/emulators/open-vm-tools/files/patch-lib_wiper_wiperPosix.c
  head/emulators/open-vm-tools/files/patch-modules_Makefile.am
  head/emulators/open-vm-tools/files/patch-modules_freebsd_vmblock_vfsops.c
  head/emulators/open-vm-tools/files/patch-modules_freebsd_vmxnet_net__compat.h
  head/emulators/open-vm-tools/files/patch-services_plugins_vix_vixTools.c