Bug 227165 - mail/cyrus-imapd25: Fix build with LibreSSL 2.7
Summary: mail/cyrus-imapd25: Fix build with LibreSSL 2.7
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Hajimu UMEMOTO
URL:
Keywords: needs-qa, patch
Depends on:
Blocks: 226843
  Show dependency treegraph
 
Reported: 2018-04-01 10:03 UTC by Bernard Spil
Modified: 2018-04-08 02:16 UTC (History)
0 users

See Also:
bugzilla: maintainer-feedback? (ume)


Attachments
svn diff for mail/cyrus-imapd25 (2.32 KB, patch)
2018-04-01 10:03 UTC, Bernard Spil
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Bernard Spil freebsd_committer 2018-04-01 10:03:46 UTC
Created attachment 192044 [details]
svn diff for mail/cyrus-imapd25

```
mail/cyrus-imapd25: Fix build with LibreSSL 2.7

 - LibreSSL 2.7 implements OpenSSL 1.1 API
 - Don't hard-depend on a Kerberos implementation

PR:
Approved by: (maintainer)
```
Comment 1 commit-hook freebsd_committer 2018-04-08 02:12:55 UTC
A commit references this bug:

Author: ume
Date: Sun Apr  8 02:11:54 UTC 2018
New revision: 466766
URL: https://svnweb.freebsd.org/changeset/ports/466766

Log:
  Fix build with LibreSSL 2.7

  PR:		227165
  Submitted by:	brnrd

Changes:
  head/mail/cyrus-imapd25/files/patch-imap__tls.c
Comment 2 Hajimu UMEMOTO freebsd_committer 2018-04-08 02:16:25 UTC
Thank you for the patch.
I've committed it.
BTW, cyrus-imapd25 has been supprting not to link Kerberos, already.