Bug 227177 - www/aria2: Fix build with LibreSSL 2.7
Summary: www/aria2: Fix build with LibreSSL 2.7
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Sunpoet Po-Chuan Hsieh
URL: https://github.com/aria2/aria2/pull/1174
Keywords: needs-qa, patch
Depends on:
Blocks: 226843
  Show dependency treegraph
 
Reported: 2018-04-01 14:53 UTC by Bernard Spil
Modified: 2018-04-05 23:10 UTC (History)
2 users (show)

See Also:
bugzilla: maintainer-feedback? (sunpoet)


Attachments
svn diff for www/aria2 (978 bytes, patch)
2018-04-01 14:53 UTC, Bernard Spil
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Bernard Spil freebsd_committer 2018-04-01 14:53:36 UTC
Created attachment 192058 [details]
svn diff for www/aria2

```
www/aria2: Fix build with LibreSSL 2.7

 - LibreSSL 2.7 implements OpenSSL 1.1 API

PR:
Approved by:
```
Comment 1 Bernard Spil freebsd_committer 2018-04-02 18:08:15 UTC
Add link to upstream pull-request https://github.com/aria2/aria2/pull/1174
Comment 2 Sunpoet Po-Chuan Hsieh freebsd_committer 2018-04-03 04:57:42 UTC
I think it should be "LIBRESSL_VERSION_NUMBER >= 0x20700000fL", right?
Comment 3 commit-hook freebsd_committer 2018-04-03 09:47:01 UTC
A commit references this bug:

Author: sunpoet
Date: Tue Apr  3 09:46:38 UTC 2018
New revision: 466299
URL: https://svnweb.freebsd.org/changeset/ports/466299

Log:
  Fix build with LibreSSL 2.7

  PR:		227177
  Submitted by:	brnrd

Changes:
  head/www/aria2/files/patch-src-libssl_compat.h
Comment 4 Sunpoet Po-Chuan Hsieh freebsd_committer 2018-04-03 10:01:02 UTC
Committed. Thanks!
Comment 5 elij 2018-04-05 23:10:04 UTC
I can no longer build with libressl-2.6.4. Could this patch be the cause.