Bug 227178 - databases/mysql56-server: Fix build with OpenSSL 1.1
Summary: databases/mysql56-server: Fix build with OpenSSL 1.1
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Mahdi Mokhtari
URL:
Keywords: needs-qa, patch
Depends on:
Blocks: 226843
  Show dependency treegraph
 
Reported: 2018-04-01 15:25 UTC by Bernard Spil
Modified: 2018-08-14 14:15 UTC (History)
3 users (show)

See Also:
mmokhi: maintainer-feedback+


Attachments
svn diff for databases/mysql56-server (7.12 KB, patch)
2018-04-01 15:25 UTC, Bernard Spil
no flags Details | Diff
mysql-PR227178-A192059-mysys.ssl.patch (777 bytes, patch)
2018-05-02 13:14 UTC, gessel
no flags Details | Diff
mysql-PR227178-A192059-my_aes_openssl.cc.patch (4.19 KB, patch)
2018-05-02 13:14 UTC, gessel
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Bernard Spil freebsd_committer 2018-04-01 15:25:50 UTC
Created attachment 192059 [details]
svn diff for databases/mysql56-server

```
databases/mysql56-server: Fix build with OpenSSL 1.1

 - Fix build with OpenSSL 1.1
 - Fixes build with LibreSSL 2.7 too

PR:
Approved by: (maintainer)
```
Comment 1 Mahdi Mokhtari freebsd_committer freebsd_triage 2018-04-03 06:13:12 UTC
Hi bernard.
Thanks for the patch, seems awesome on build...
I'm trying to [re-]use it for 57 and 80 as well, the latter maybe comes a little [really a little :D] tricky...

I'm now testing the patchs for the rc-regression by 0mp on PR#227231 (and two others), then I'll continue the thing on 80 and commit all in once :D is this OK IYO?
Comment 2 gessel 2018-05-02 13:14:03 UTC
Created attachment 192995 [details]
mysql-PR227178-A192059-mysys.ssl.patch

Tried against mysql56-server-5.6.40, some issues...
Comment 3 gessel 2018-05-02 13:14:52 UTC
Created attachment 192996 [details]
mysql-PR227178-A192059-my_aes_openssl.cc.patch

tried against mysql56-server-5.6.40
Comment 4 gessel 2018-05-02 13:16:45 UTC
I tried the attached patches against mysql56-server-5.6.40, which was building cleanly without them and starting without reporting errors.  

Once /files was updated with these patches, I get on # make

===>  Applying FreeBSD patches for mysql56-server-5.6.40
Ignoring previously applied (or reversed) patch.
1 out of 1 hunks ignored--saving rejects to include/my_compare.h.rej
=> FreeBSD patch patch-include_my_compare.h failed to apply cleanly.
=> Patch(es)  patch-CMakeLists.txt patch-client_CMakeLists.txt patch-cmake_plugin.cmake patch-cmake_ssl.cmake patch-extra_CMakeLists.txt patch-include_CMakeLists.txt patch-include_my__compare.h applied cleanly.
*** Error code 1

Stop.
make: stopped in /usr/ports/databases/mysql56-server
Comment 5 commit-hook freebsd_committer 2018-05-07 19:09:29 UTC
A commit references this bug:

Author: brnrd
Date: Mon May  7 19:09:03 UTC 2018
New revision: 469311
URL: https://svnweb.freebsd.org/changeset/ports/469311

Log:
  databases/mysql56-server: Fix build with LibreSSL

  PR:		227178
  Approved by:	mmokhi (maintainer)

Changes:
  head/databases/mysql56-server/files/patch-mysys__ssl_my__aes__openssl.cc
  head/databases/mysql56-server/files/patch-vio_viosslfactories.c
Comment 6 Martin Wilke freebsd_committer 2018-05-20 16:13:53 UTC
Close since its patched.
Comment 7 commit-hook freebsd_committer 2018-08-14 14:15:26 UTC
A commit references this bug:

Author: mmokhi
Date: Tue Aug 14 14:15:02 UTC 2018
New revision: 477156
URL: https://svnweb.freebsd.org/changeset/ports/477156

Log:
  MFH: r469311 r476853

  databases/mysql56-server: Fix build with LibreSSL

  PR:		227178
  Approved by:	mmokhi (maintainer)

  mysql56-{client, server}: Update ports to 5.6.41
  This update includes Oracle Critical Patch Advisory published on July 2018
  More info:
  http://www.oracle.com/technetwork/security-advisory/cpujul2018-4258247.html#AppendixMSQL

  Sponsored by:	The FreeBSD Foundation

  Approved by:	ports-secteam (feld)

Changes:
_U  branches/2018Q3/
  branches/2018Q3/databases/mysql56-server/Makefile
  branches/2018Q3/databases/mysql56-server/distinfo