Bug 227209 - [patch] sysutils/geomWatch stable/11-llvm6 (r331838) fallout [-W reserved-user-defined-literal]
Summary: [patch] sysutils/geomWatch stable/11-llvm6 (r331838) fallout [-W reserved-use...
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: freebsd-ports-bugs mailing list
URL:
Keywords:
: 230261 (view as bug list)
Depends on:
Blocks:
 
Reported: 2018-04-02 18:16 UTC by Harald Schmalzbauer
Modified: 2018-08-08 14:59 UTC (History)
4 users (show)

See Also:
bugzilla: maintainer-feedback? (spawk)


Attachments
zfs-sysevent.h: Insert whitespaces for C++11 compile werror. (1.18 KB, patch)
2018-04-02 18:16 UTC, Harald Schmalzbauer
no flags Details | Diff
zfs-sysevent.h: Insert whitespaces for C++11 compile werror. (846 bytes, patch)
2018-04-02 18:20 UTC, Harald Schmalzbauer
no flags Details | Diff
Make geomWatch obey USE_CXXSTD=gnu++98 option (1.19 KB, patch)
2018-04-03 15:40 UTC, Dimitry Andric
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Harald Schmalzbauer 2018-04-02 18:16:14 UTC
Created attachment 192113 [details]
zfs-sysevent.h: Insert whitespaces for C++11 compile werror.

After r331838, geomwatch fails to compile with:
In file included from geomWatch.cpp:41:                                         
In file included from ./zpool.hpp:35:                                           
In file included from zfs/v28/cddl/contrib/opensolaris/lib/libzfs/common/libzfs.h:38:
In file included from zfs/v28/sys/cddl/contrib/opensolaris/uts/common/fs/zfs/sys/zfs_ioctl.h:30:
In file included from zfs/v28/sys/cddl/contrib/opensolaris/uts/common/fs/zfs/sys/zio.h:29:
In file included from zfs/v28/cddl/contrib/opensolaris/lib/libzpool/common/sys/zfs_context.h:83:
zfs/v28/sys/cddl/contrib/opensolaris/uts/common/sys/sysevent.h:79:37: error: invalid suffix on literal; C++11 requires a space between literal and identifier [-W
reserved-user-defined-literal]                                                  
#define SUNW_KERN_PUB   SUNW_VENDOR":"SE_KERN_PUB

Attached is q q'n'd patch to sysutils/geomWatch (the port).

-harry
Comment 1 Harald Schmalzbauer 2018-04-02 18:20:38 UTC
Created attachment 192115 [details]
zfs-sysevent.h: Insert whitespaces for C++11 compile werror.

Sorry, file-attachment seems to have interfered with the wrong one I pasted...
Comment 2 Harald Schmalzbauer 2018-04-02 18:22:45 UTC
Ahh, "details" and "diff" differ...
Only the "details" show to patch-patch, "diff" decapsules the inner patch.

-harry
Comment 3 Dimitry Andric freebsd_committer 2018-04-03 15:40:49 UTC
Created attachment 192170 [details]
Make geomWatch obey USE_CXXSTD=gnu++98 option

Here is an alternate patch, which:
* Makes geomWatch obey the USE_CXXSTD setting, by adding ${CXXFLAGS} to the compilation command line.
* Sets USE_CXXSTD to gnu++98, so no messing with the ZFS code needs to be done.
Comment 4 Dmitri Goutnik 2018-08-03 13:28:05 UTC
*** Bug 230261 has been marked as a duplicate of this bug. ***
Comment 5 commit-hook freebsd_committer 2018-08-08 14:59:14 UTC
A commit references this bug:

Author: dvl
Date: Wed Aug  8 14:58:33 UTC 2018
New revision: 476645
URL: https://svnweb.freebsd.org/changeset/ports/476645

Log:
  Fix broken building

  PR:		227209
  Submitted by:	Harald Schmalzbauer <bugzilla.freebsd@omnilan.de> Dmitri Goutnik <dg@syrec.org>
  Approved by:	maintainer (timeout 4 months))

Changes:
  head/sysutils/geomWatch/Makefile
  head/sysutils/geomWatch/files/patch-Makefile
Comment 6 Dan Langille freebsd_committer 2018-08-08 14:59:37 UTC
Thank you both.