Bug 227215 - databases/mongodb34: Adapt mongod_limits to the new resource limiting mechanics for services
Summary: databases/mongodb34: Adapt mongod_limits to the new resource limiting mechani...
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Thomas Zander
URL:
Keywords: patch-ready, regression
Depends on:
Blocks: 227205
  Show dependency treegraph
 
Reported: 2018-04-02 22:57 UTC by Mateusz Piotrowski
Modified: 2018-04-30 13:43 UTC (History)
2 users (show)

See Also:
eric: maintainer-feedback+
0mp: maintainer-feedback?


Attachments
Patch adding support for the new ${name}_limits mechanics (databases/mongodb34) (2.57 KB, patch)
2018-04-02 22:57 UTC, Mateusz Piotrowski
no flags Details | Diff
Patch adding support for the new ${name}_limits mechanics (databases/mongodb34, revision: 1) (2.57 KB, patch)
2018-04-04 18:03 UTC, Mateusz Piotrowski
no flags Details | Diff
Patch adding support for the new ${name}_limits mechanics (databases/mongodb34, revision: 4) (2.52 KB, patch)
2018-04-11 00:08 UTC, Mateusz Piotrowski
0mp: maintainer-approval?
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Mateusz Piotrowski freebsd_committer 2018-04-02 22:57:29 UTC
Created attachment 192128 [details]
Patch adding support for the new ${name}_limits mechanics (databases/mongodb34)

Thanks to the recent change to rc.subr(8) it is no longer necessary to
define a resource limiting logic in service scripts. limits(1) is now run
by default and its configuration is handled via the "${name}_limits"
variable.

Unfortunately, there is a collision of variable names. The service
scripts are broken on FreeBSD version with that new change (12.0-CURRENT,
11-STABLE and soon 11.2-RELEASE). It has been reported and diagnosed here.[2]

I'm submitting a patch fixing the service script for this port. A similar patch
has already been accepted by a maintainer of another database port.[2]

The patch preserves the old behavior on the systems without the
modification.

[1]: https://svnweb.freebsd.org/base?view=revision&revision=r328331
[2]: https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=226907
Comment 1 Mateusz Piotrowski freebsd_committer 2018-04-04 18:03:35 UTC
Created attachment 192219 [details]
Patch adding support for the new ${name}_limits mechanics (databases/mongodb34, revision: 1)

The previous patch would fail to trigger the new ${name}_limits semantics for __FreeBSD_version 1101514. The new patch fixes it (thanks to mmokhi@).
Comment 2 Mateusz Piotrowski freebsd_committer 2018-04-11 00:08:57 UTC
Created attachment 192405 [details]
Patch adding support for the new ${name}_limits mechanics (databases/mongodb34, revision: 4)

Due to an increasing number of problems caused by the new ${name}_limits behavior, the revision, which was backported from 12-CURRENT to 11-STABLE, has now been reverted.[1] As a result, the new behavior will not be present in any FreeBSD version < 12. 

This new patch adapts the port to those latest changes.

[1]: https://svnweb.freebsd.org/base?view=revision&revision=r332363
Comment 3 commit-hook freebsd_committer 2018-04-30 13:18:35 UTC
A commit references this bug:

Author: riggs
Date: Mon Apr 30 13:17:51 UTC 2018
New revision: 468698
URL: https://svnweb.freebsd.org/changeset/ports/468698

Log:
  Adapt mongod_limits to the new resource limiting mechanics for services

  PR:		227215
  Submitted by:	0mp
  Approved by:	eric@camachat.org (maintainer)

Changes:
  head/databases/mongodb34/Makefile
  head/databases/mongodb34/files/mongod.in