Bug 227233 - databases/mysqlwsrep57-server: Adapt ${name}_limits to the new resource limiting mechanics for services
Summary: databases/mysqlwsrep57-server: Adapt ${name}_limits to the new resource limit...
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: freebsd-ports-bugs mailing list
URL:
Keywords: patch-ready, regression
Depends on:
Blocks: 227205
  Show dependency treegraph
 
Reported: 2018-04-03 01:14 UTC by Mateusz Piotrowski
Modified: 2018-06-13 06:27 UTC (History)
1 user (show)

See Also:
0mp: maintainer-feedback?


Attachments
Patch adding support for the new ${name}_limits mechanics (databases/mysqlwsrep57-server) (2.80 KB, patch)
2018-04-03 01:14 UTC, Mateusz Piotrowski
no flags Details | Diff
Patch adding support for the new ${name}_limits mechanics (databases/mysqlwsrep57-server, revision: 1) (2.80 KB, patch)
2018-04-04 18:17 UTC, Mateusz Piotrowski
no flags Details | Diff
Patch adding support for the new ${name}_limits mechanics (databases/mysqlwsrep57-server, revision: 4) (2.75 KB, patch)
2018-04-11 00:19 UTC, Mateusz Piotrowski
0mp: maintainer-approval?
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Mateusz Piotrowski freebsd_committer 2018-04-03 01:14:32 UTC
Created attachment 192149 [details]
Patch adding support for the new ${name}_limits mechanics (databases/mysqlwsrep57-server)

Thanks to the recent change to rc.subr(8) it is no longer necessary to
define a resource limiting logic in service scripts. limits(1) is now run
by default and its configuration is handled via the "${name}_limits"
variable.

Unfortunately, there is a collision of variable names. The service
scripts are broken on FreeBSD version with that new change (12.0-CURRENT,
11-STABLE and soon 11.2-RELEASE). It has been reported and diagnosed here.[2]

I'm submitting a patch fixing the service script for this port. A similar patch
has already been accepted by a maintainer of another database port.[2]

The patch preserves the old behavior on the systems without the
modification.

It would be great if you could review the patch and test it. :)

[1]: https://svnweb.freebsd.org/base?view=revision&revision=r328331
[2]: https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=226907
Comment 1 Bugzilla Automation freebsd_committer 2018-04-03 01:14:32 UTC
Maintainer informed via mail
Comment 2 Mateusz Piotrowski freebsd_committer 2018-04-04 18:17:50 UTC
Created attachment 192228 [details]
Patch adding support for the new ${name}_limits mechanics (databases/mysqlwsrep57-server, revision: 1)

The previous patch would fail to trigger the new ${name}_limits semantics for __FreeBSD_version 1101514. The new patch fixes it (thanks to mmokhi@).
Comment 3 Mateusz Piotrowski freebsd_committer 2018-04-11 00:19:09 UTC
Created attachment 192414 [details]
Patch adding support for the new ${name}_limits mechanics (databases/mysqlwsrep57-server, revision: 4)

Due to an increasing number of problems caused by the new ${name}_limits behavior, the revision, which was backported from 12-CURRENT to 11-STABLE, has now been reverted.[1] As a result, the new behavior will not be present in any FreeBSD version < 12. 

This new patch adapts the port to those latest changes.

[1]: https://svnweb.freebsd.org/base?view=revision&revision=r332363
Comment 4 commit-hook freebsd_committer 2018-06-13 06:24:36 UTC
A commit references this bug:

Author: vd
Date: Wed Jun 13 06:23:29 UTC 2018
New revision: 472290
URL: https://svnweb.freebsd.org/changeset/ports/472290

Log:
  databases/mysqlwsrep57-server: Fix ${name}_limits clash

  PR:		227233
  Submitted by:	0mp

Changes:
  head/databases/mysqlwsrep57-server/Makefile
  head/databases/mysqlwsrep57-server/files/mysql-server.in
Comment 5 Vasil Dimov freebsd_committer 2018-06-13 06:27:35 UTC
Committed, thanks!