Bug 227254 - [New Port] cad/abc: System for Sequential Synthesis and Verification
Summary: [New Port] cad/abc: System for Sequential Synthesis and Verification
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Yuri Victorovich
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-04-03 13:15 UTC by Christian Krämer
Modified: 2018-04-24 07:54 UTC (History)
1 user (show)

See Also:


Attachments
shar archive of devel/abc (3.29 KB, text/plain)
2018-04-03 13:15 UTC, Christian Krämer
no flags Details
shar archive of cad/abc (3.29 KB, text/plain)
2018-04-04 10:11 UTC, Christian Krämer
no flags Details
shar archive of cad/abc (4.04 KB, text/plain)
2018-04-11 20:44 UTC, Christian Krämer
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Christian Krämer 2018-04-03 13:15:30 UTC
Created attachment 192167 [details]
shar archive of devel/abc

ABC is a growing software system for synthesis and verification of binary
sequential logic circuits appearing in synchronous hardware designs. ABC
combines scalable logic optimization based on And-Inverter Graphs (AIGs),
optimal-delay DAG-based technology mapping for look-up tables and standard
cells, and innovative algorithms for sequential synthesis and verification.

ABC provides an experimental implementation of these algorithms and a
programming environment for building similar applications. Future development
will focus on improving the algorithms and making most of the packages
stand-alone. This will allow the user to customize ABC for their needs as if
it were a tool-box rather than a complete tool.

WWW: https://people.eecs.berkeley.edu/~alanmi/abc/

portlint: looks fine.
poudriere: build successful.
Comment 1 Yuri Victorovich freebsd_committer 2018-04-04 05:49:17 UTC
Shouldn't it be under cad/?
Comment 2 Christian Krämer 2018-04-04 10:09:57 UTC
(In reply to Yuri Victorovich from comment #1)
You are right. On second thought, cad seems more suitable...
Comment 3 Christian Krämer 2018-04-04 10:11:56 UTC
Created attachment 192205 [details]
shar archive of cad/abc
Comment 4 Yuri Victorovich freebsd_committer 2018-04-05 16:25:53 UTC
It fails on 10 i386:
In file included from ./src/misc/vec/vec.h:29:
./src/misc/util/abc_global.h:121:5: error: unsupported platform
   #error unsupported platform
    ^
Comment 5 Christian Krämer 2018-04-11 20:43:54 UTC
(In reply to Yuri Victorovich from comment #4)
A small part of the project is written in C++ but uses the normal C standard library header files. The Problem was caused by the inclusion of stdint.h which does not define the necessary macros per default when compiling C++ code. In libc++ of 11.1 a header file was added as wrapper for stdint.h which defines additional macros that make stdint.h define the missing macros although __cplusplus is defined.

I added a patch that defines these macros before including stdint.h. Now it builds also on versions < 11.1.
Comment 6 Christian Krämer 2018-04-11 20:44:48 UTC
Created attachment 192438 [details]
shar archive of cad/abc
Comment 7 Yuri Victorovich freebsd_committer 2018-04-24 07:53:35 UTC
Committed with changes and additions.
Thank you for your contribution!
Comment 8 commit-hook freebsd_committer 2018-04-24 07:54:29 UTC
A commit references this bug:

Author: yuri
Date: Tue Apr 24 07:53:30 UTC 2018
New revision: 468187
URL: https://svnweb.freebsd.org/changeset/ports/468187

Log:
  New port: cad/abc: System for sequential synthesis and verification

  PR:		227254
  Submitted by:	Christian Kr?mer <uddka@student.kit.edu>

Changes:
  head/cad/Makefile
  head/cad/abc/
  head/cad/abc/Makefile
  head/cad/abc/distinfo
  head/cad/abc/files/
  head/cad/abc/files/patch-Makefile
  head/cad/abc/files/patch-src_misc_util_abc__global.h
  head/cad/abc/pkg-descr