Bug 227453 - net/pecl-smbclient; in poudriere, it fails to build due to Samba 4.8
Summary: net/pecl-smbclient; in poudriere, it fails to build due to Samba 4.8
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Many People
Assignee: freebsd-ports-bugs (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-04-12 06:40 UTC by O. Hartmann
Modified: 2018-04-12 08:56 UTC (History)
2 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description O. Hartmann 2018-04-12 06:40:01 UTC
When poudriere built repositories have

DEFAULT_OPTIONS+=samba=4.8

set in the poudriere-specific make.conf file, several ports fail to build due to the error:

Invalid version of samba: 4.8

Building the port 

net/pecl-smbclient

the classical BSDish way (via make), there is a message, that the requirement of Samba 4.7 is handled bt net/samba48 and the port compiles and successfully installs.
Comment 1 commit-hook freebsd_committer 2018-04-12 08:55:00 UTC
A commit references this bug:

Author: timur
Date: Thu Apr 12 08:54:30 UTC 2018
New revision: 467131
URL: https://svnweb.freebsd.org/changeset/ports/467131

Log:
  Add Samba 4.8 as possible default version, remove obsolete Samba 4.4

  PR:		227453
  Sponsored by:	iXsystems Inc.

Changes:
  head/Mk/Uses/samba.mk
Comment 2 Timur I. Bakeyev freebsd_committer 2018-04-12 08:56:07 UTC
Committed, thanks!